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Tech Tip : CA Single Sign-On : Unable to start the Admin UI for Single Sign On(Site-minder)

  • 1.  Tech Tip : CA Single Sign-On : Unable to start the Admin UI for Single Sign On(Site-minder)

    Broadcom Employee
    Posted May 16, 2019 05:43 AM

    Issue:

     

    When we're starting the AdminUI, this one cannot start properly and
    report error :

     

    Error: Protocol handler initialization failed,
    java.net.mindexception address already in use

     

    How can we solve it ?


    Cause:


    At first glance, you get this error because :

     

    - Another process than the AdminUI is running and uses one of the
      ports needed by the AdminUI;
    - There still another instance of the AdminUI running and using
       already all the AdminUI ports;
    - There's a permission issue on the OS;

    Resolution:

     

    - Identify the process that uses those ports :

     

    5455
    8080
    8443
    5445

     

    Run command as root :

     

    # for i in 5455 8080 8443 5445; do ss -tanp | grep $i; done;

     

    You should get something like :

     

    LISTEN 0 128 *:5455 *:* users:(("java",pid=1615,fd=363))
    LISTEN 0 50 *:8080 *:* users:(("java",pid=1615,fd=309))
    LISTEN 0 50 *:8443 *:* users:(("java",pid=1615,fd=396))
    LISTEN 0 128 *:5445 *:* users:(("java",pid=1615,fd=373))

     

    In this sample, the PID 1615 is using these ports.

    Identify what is the 1615 process and stop it or remove it from the
    system memory using the kill program.

     

    Once the PID doesn't show up in memory, run again the command :

     

    # for i in 5455 8080 8443 5445; do ss -tanp | grep $i; done;

    This time, it should return nothing;

     

    Then start the AdminUI and confirm us this solves the issue; Insure
    there's no permission problem for the AdminUI process and user on
    the OS;

     

    KB : KB000132274