Symantec Access Management

Expand all | Collapse all

Metabase error -41737 in IIS while reconfiguring SM

  • 1.  Metabase error -41737 in IIS while reconfiguring SM

    Posted 12-20-2014 08:11 AM

    Hi experts,

     

    Recently I ve attempted to reconfigure SM for an App in an IIS server, which ended up incomplete with below error:

     

    Metabase error : -41737

    Unable to remove Mime types:*==D:\Program files\CA\webagent\bin\ISAPI6WebAgent.dll

     

    Such errors are repeating with different codes for different directories.

    Can someone please help me to understand this specific issue and resolve it?

     

    Background:

    A dedicated server with single application, where SM got messed up after few codes were deployed to the website.

     

     

    Thanks in advance.



  • 2.  Re: Metabase error -41737 in IIS while reconfiguring SM

    Posted 03-26-2015 03:01 PM

    Could someone assist muralinitk here?



  • 3.  Re: Metabase error -41737 in IIS while reconfiguring SM

    Posted 03-27-2015 09:07 AM

    it appears to be permission issues

     

    I would try following

    1) disable the application and see if SM works okay

     

    2) review application deployment web config etc for least permission if possible.

     

    if problem persists

    a) remove application and SM

    b) fresh install / configure as needed

    c) test ; f server starts fine

    d) deploy sample app ; test its still okay

    e) deploy the application ; test ; if works es expected

    f) if it still complains application gets the blame not SM



  • 4.  Re: Metabase error -41737 in IIS while reconfiguring SM

    Posted 03-27-2015 09:29 AM

    additional steps

     

    Turn windows features on or off

     

    Go to Control Panel -> Programs and Features -> Turn Windows Features on or off

     

    select Internet Information Services -> Web Management Tools -> IIS 6 Management Compatibility -> IIS Metabase and IIS 6 configuration compatibility.

     

    if struggle continues ; try :

     

    turn on / off the IIS and .Net Framework features