DX Operational Intelligence

Expand all | Collapse all

DOI APM Integration

  • 1.  DOI APM Integration

    Posted 09-16-2019 11:15 AM
    Hi colleagues,

    We have APM 11.1 running and DOI 1.3.1 running as well. In DOI we set Data Source CA APM Topology. It is verified and saved successfully BUT nothing happens. We see no data in Source of service. There is also no data neither in Topology Store no in Imported topologies. What else should we do to get data from APM?
    In performance section we see no devices or applications discovered and monitored by APM.

    Thank you


  • 2.  RE: DOI APM Integration

    Posted 09-16-2019 11:23 AM
    Hi Andrey,

    the minimum version to integrate APM with DOI is CA APM 10.7 SP3 (plus Hotfix CHF35).
    Please see here: https://docops.ca.com/ca-digital-operational-intelligence/1-3/en/installing/integration/integrate-ca-products/add-ca-apm   or here https://docops.ca.com/ca-digital-operational-intelligence/1-3/en/release-notes/release-notes-1-3-1/compatibility-matrix-for-1-3-1

    Which connector plugin do you use?

    Michael


    ------------------------------
    Customer Success Architect
    CA Deutschland GmbH (a Broadcom company)
    ------------------------------



  • 3.  RE: DOI APM Integration

    Posted 09-16-2019 11:42 AM
      |   view attached
    Hi Michael,
    We have APM 11.1. When we connect to embedded DOI, the one which is installed together with APM, we can see in DOI interface  APM metrics but no CIs to add to a service. When we tried to add CA APM Topology it was successfully verified but we get error on saving - "Precondition failed"​ (see screenshot attached). We suppose that "embedded" DOI has restricted functionality (there is no "Logs" section in interface for instance) ​that is why we installed DOI 1.3.1 and now try to integrate it with APM. We also have a problem with Spectrum integration . The Jarvis /injection method returned error 503 - Service unavailable.


  • 4.  RE: DOI APM Integration

    Posted 09-17-2019 01:10 AM
    Hi Andrey
    I would start by checking which data you have in your OI system (e.g. verify your apm and spectrum elastic indexes). Once the CIs are there we can move to Service Creation.
    Regarding Spectrum integration, have you installed and configured the SpectrumDataPublisher connector? If yes, we can explore the logs to see if there are any issues
    HTH
    Nestor


  • 5.  RE: DOI APM Integration

    Posted 09-26-2019 05:54 AM
    Hi Michael,
    We've changed our configuration and now we have APM 10.7 SP3 and DOI 1.3.1
    On the APM side we've done DOI integration and now we can see in DOI Performance tab devices and applications from APM.
    But we can not see metrics for these devices and application - we get "no results found"​
    At the same time in Logs tab we see that metrics messages do come from APM.
    What is the magic to make these metrics to be seen in performance?

    P.S. We try to integrate Zabbix with DOI and have arranged metrics from Zabbix to be sent to DOI and we see them.


  • 6.  RE: DOI APM Integration

    Posted 09-26-2019 06:12 AM
    Hi Andrey,

    just for version checking:
    Did you install any Hotfix on top of 10.7 SP3?
    Minimum HF43 is required (changed to my previous entry with HF35).

    Michael


    ------------------------------
    Customer Success Architect
    CA Deutschland GmbH (a Broadcom company)
    ------------------------------



  • 7.  RE: DOI APM Integration

    Posted 09-27-2019 06:44 AM
    Hi Michael,
    we've installed HF43 but nothing changed. We see metrics messages in Log but no data in performance.
    I think it is important - we have on premise installation for both APM and DOI.