CA Service Management

Expand all | Collapse all

Post Upgrade From SDM 12.9 to SDM 17.1.0.11 Attach Event BHVEVTATTACH Macros Not Firing

  • 1.  Post Upgrade From SDM 12.9 to SDM 17.1.0.11 Attach Event BHVEVTATTACH Macros Not Firing

    Posted 9 days ago
    Hello,

    During the testing phase of our SDM 12.9 to SDM 17.1.0.11 upgrade, we have detected that "Attach Event" macros (Code = BHVEVTATTACH) are not firing.

    There is nothing obvious within the stdlog even with pdm_logstat -n animator_nxd verbose and or pdm_logstat -a 0 set.

    We have tried following Events are not not firing in CA Service Desk Manager and dropping all rows within [mdb].[dbo].[anima].

    I've tried creating a new Attach Event in 17.1.0.11 but the issue remains. Any ideas on how to troubleshoot further?

    Thanks
    Stuart


  • 2.  RE: Post Upgrade From SDM 12.9 to SDM 17.1.0.11 Attach Event BHVEVTATTACH Macros Not Firing

    Broadcom Employee
    Posted 4 days ago
    Hi Stuart,

    Any reason you upgraded to r17.1, when it just went EOS on 30 Sep 2021?

    https://community.broadcom.com/enterprisesoftware/communities/community-home/digestviewer/viewthread?MessageKey=3f5a001c-684a-4334-926e-8ab0120a82b1&CommunityKey=e2cd3188-49bc-4f38-88f1-74260f56fa66&tab=digestviewer#bm3f5a001c-684a-4334-926e-8ab0120a82b1

    I would suggest you upgrade the current r17.1_RU11 to r17.2 or r17.3 and apply the latest RU on top of the base upgraded supported version. If the problem still persist, then log a support case for further investigation.

    ------------------------------
    Kind Regards,
    Brian
    [JobTitle]
    [Country]
    ------------------------------



  • 3.  RE: Post Upgrade From SDM 12.9 to SDM 17.1.0.11 Attach Event BHVEVTATTACH Macros Not Firing

    Posted 3 days ago
    Anyone else on SDM 17.1.0.11 with this issue, log a Broadcom case and ask for T5UG455


  • 4.  RE: Post Upgrade From SDM 12.9 to SDM 17.1.0.11 Attach Event BHVEVTATTACH Macros Not Firing

    Posted 3 days ago
    It would really appreciate if I could find out more about this known issue and its cause & fix.

    https://knowledge.broadcom.com/external/article?articleId=201936

    Issue/Introduction


    After ServiceDesk  17.3 environment was upgraded to 17.3.0.1, the events that should be attached to the ticket with Attach Event Macros no longer run.

    Steps to reproduce:

    1. Create an Event with name: abcEvent
    Object Type : Request/Incident/Problem
    Delay Time: 00:00:30
    Condition : Req. Status = Open
    Repeat Delay Time : 00:00:00


    2. Create a macro with details:
    Symbol : abcMacro_to_attach_abcEvent
    Object Type : Request/Incident/Problem
    Macro Type: Attach Event
    Event : abcEvent (The one created in step1)


    3. Create another macro with details:
    Symbol : zAction on True
    Object Type : Request/Incident/Problem
    Macro Type : Action
    Macro Code : logf(SIGNIFICANT,"---> true
    action");


    4. Open Init activity notification
    Update the event with "abcEvent"


    5. Try to create R/I/P ticket.


    Result:  We see the event does not gets attached.
    Expected result: When abcEvent triggers, it need to attach the same event "abcEvent".

    Cause

    DE58131

    Resolution

    The correction of this problem should be available via a test fix patch.
    Please open a Technical Support issue to request it if desired.

    PRODUCT: Unicenter Service Desk                          RELEASE: 17.3

    FN: T5UG444    DATE:    15 Oct 2020 

    PROBLEM SYMPTOM: WIN-FAILED TO CALCULATE PROJECTED VIOLATION