Clarity Service Management

Expand all | Collapse all

17.1 ITAM upgrade failing

Jump to Best Answer
  • 1.  17.1 ITAM upgrade failing

    Posted 09-09-2019 04:29 PM
    Hi Team,

    We are upgrading our ITAM from 12.9 to 17.1 and it fails and below is the log file, any inputs please.

    2019/09/09 11.24.28.420 DEBUG [DeployThread: Installing CA Asset Portfolio Management Database] [CommonProcessUtilities] 09-09,11:24:28 MDBTools install error=3
    2019/09/09 11.24.28.839 DEBUG [DeployThread: Installing CA Asset Portfolio Management Database] [CommonProcessUtilities] 09-09,11:24:28 Setupmdb exit /B return code=3
    2019/09/09 11.24.28.849 INFO [DeployThread: Installing CA Asset Portfolio Management Database] [ActiveProcessHolder] Exit Monitor. Process ID (PID): 10292
    2019/09/09 11.24.28.850 INFO [DeployThread: Installing CA Asset Portfolio Management Database] [CommonProcessUtilities] Command terminated with error
    2019/09/09 11.24.28.850 DEBUG [DeployThread: Installing CA Asset Portfolio Management Database] [ITAMConfigTask] 3
    2019/09/09 11.24.28.851 DEBUG [DeployThread: Installing CA Asset Portfolio Management Database] [ProgressPage] ProgressPage - Task Changed Installing CA Asset Portfolio Management Database
    2019/09/09 11.24.28.851 DEBUG [DeployThread: Installing CA Asset Portfolio Management Database] [ProgressPage] Task State Changed. TaskID: task.installDB_Itam,Installing CA Asset Portfolio Management Database, Old State: running, New State:failed
    2019/09/09 11.24.28.852 INFO [DeployThread: Installing CA Asset Portfolio Management Database] [DeployThread] Saving task status to DB for task task.installDB_Itam
    2019/09/09 11.24.28.852 INFO [DeployThread: Installing CA Asset Portfolio Management Database] [DeployThread] Saving task 'task.installDB_Itam' status to DB ....
    2019/09/09 11.24.28.852 INFO [DeployThread: Installing CA Asset Portfolio Management Database] [DatabasePersister] Saving component install state to database.
    2019/09/09 11.24.28.852 DEBUG [DeployThread: Installing CA Asset Portfolio Management Database] [DatabasePersister] Insert/Update Parameters: productCode (3); currVersion (17.1); status(failed); packageId(task.installDB_Itam)
    2019/09/09 11.24.28.900 DEBUG [DeployThread: Installing CA Asset Portfolio Management Database] [DatabasePersister] Query Parameters: lower(machineName) - (servername); lower(packageid) - (task.installdb_itam); productCode(3)
    2019/09/09 11.24.28.903 INFO [DeployThread: Installing CA Asset Portfolio Management Database] [DatabasePersister] al_cdb_componentinstallstate count 1
    2019/09/09 11.24.28.907 DEBUG [DeployThread: Installing CA Asset Portfolio Management Database] [DatabasePersister] Update to al_cdb_componentinstallstate successful
    2019/09/09 11.24.28.908 INFO [DeployThread: Installing CA Asset Portfolio Management Database] [DeployThread] Task 'task.installDB_Itam' status saved to DB ....
    2019/09/09 11.24.28.908 DEBUG [DeployThread: Installing CA Asset Portfolio Management Database] [ProgressPage] ProgressPage - Task Error.
    2019/09/09 11.24.28.908 DEBUG [DeployThread: Installing CA Asset Portfolio Management Database] [ProgressPage] Task Error. TaskID: task.installDB_Itam,Installing CA Asset Portfolio Management Database
    2019/09/09 11.24.43.696 DEBUG [DeployThread: Installing CA Asset Portfolio Management Database] [Task] inside initErrMap() generic. This method should be overloaded if possible
    2019/09/09 11.24.44.696 INFO [DeployThread] [DeployThread] task.installDB_Itam : failed
    2019/09/09 11.24.44.696 INFO [DeployThread] [DeployThread] Abort requested while running task: Installing CA Asset Portfolio Management Database



    Thanks & Regards,
    Avinash Kande


  • 2.  RE: 17.1 ITAM upgrade failing

     
    Posted 09-10-2019 02:54 AM
    Hello Avinash,

    Check out the install_mdb.log also and see if it is a match to this.

    MDBTools install error=3 when upgrading to CA Service Management 17.2. Setupmdb exit /B return code=3. com.microsoft.sqlserver.jdbc.SQLServerException: The index 'evt_x0' is dependent on column 'sym'.

    Thanks, Kyle_R.





  • 3.  RE: 17.1 ITAM upgrade failing
    Best Answer

    Posted 09-11-2019 01:49 AM
    Hi Avinash,

    You mentioned that you are upgrading from 12.9 to 17.x version. This is not the correct path for an upgrade. The recommended path is 12.9 --> 14.1 --> 17.1. 

    Thank You,
    Shiva