CA Service Management

Expand all | Collapse all

spl not recognized in custom webengine

  • 1.  spl not recognized in custom webengine

    Posted 06-27-2017 03:43 AM

    Hi,

     

    we are using CASD14.1 with c2 patch.

     

    we have one application server and we have configure 2 webengine ( one is default pdmweb.exe and other is pdmweb1.exe).

     

    whenever we do spl customization and place the file in application servers the spl functionality and behaviour is working fine in http://server/CAisd/pdmweb.exe but the spl functionality behaviour is throwing error I mean the spl whatever we copied in application server is not recognized in http://server/CAisd/pdmweb1.exe

     

     

    Does any one know or help why the spl is working fine in pdmweb.exe url but not in pdmweb1.exe url.



  • 2.  Re: spl not recognized in custom webengine

    Broadcom Employee
    Posted 07-03-2017 07:51 AM

    Hi ..

    Could you review the stdlog and share the error message. Which should give us better insight.

    ~Vinod.



  • 3.  Re: spl not recognized in custom webengine

    Posted 06-27-2017 10:29 AM

    hi,

     

    webengine spl or spel_srvr spl?

     

    if it's webengine spl, you have to define the spl file in webengines cfg file.

     

    greets



  • 4.  Re: spl not recognized in custom webengine

    Posted 06-27-2017 09:03 AM

    I Subbarao,

    Can you tell me exactly what the error is that you are getting as well as information about what the custom spl file does?  Unfortunatley Spel customizations are outside the scope of support so we cant really do a deep-dive analysis into your custom file, but if you can give us an idea of the purpose of the custom file and what its supposed to do, along with the error, we may be able to at least point you in the right direction.

    Thanks,

    Jon I.



  • 5.  Re: spl not recognized in custom webengine

    Posted 06-27-2017 10:47 AM

    Hi,

     

    Its a webengine spl only.

     

    can you tell me the path where I can get the webegines cfg file and how to define fpl file in it?



  • 6.  Re: spl not recognized in custom webengine

    Posted 07-03-2017 03:13 AM

    hi,

     

    the file for pdmweb.exe is NX_ROOT\bopcfg\www\web.cfg. to make your changes persistent, change NX_ROOT/samples/pdmconf/web.cfg.tpl, too. pdmweb1.exe's file should be something like pdmweb1_web.cfg (you can have a look into cfg files, there you can see in the first couple of lines the used CGI for this specific cfg file).

     

    find the line with "freeaccess.spl" at the end and add your filename blank seperated (have a look into well working web.cfg's correspondending line). do the same for the line with "op_table.cfg".

     

    restart webengine

     

    regards

    marc