CA Service Management

Expand all | Collapse all

Error to execute web form

Jump to Best Answer
  • 1.  Error to execute web form

    Posted 12-15-2017 06:41 AM

    Hi everyone,

     

    I'm creating a Web Form to open a report when the user access the report tab on SDM.

     

    I've created the Web Form:

     

    Path's report and report name:

     

     

    But when I've tried to execute the Web Form, the error occurred:

     

     

     

    I know that is permition, but I couldn't find where is. Anyone knows which permission I have to give to open the report?

     

    Thanks.

     

    Regards,

    Felipe Nunes



  • 2.  Re: Error to execute web form

    Posted 12-15-2017 07:06 AM

    hi

    I don't think you need the [Public+Folders] as this is already the root path

    My 2 cents

    /J



  • 3.  Re: Error to execute web form

    Broadcom Employee
    Posted 12-15-2017 07:45 AM

    Hi Felipe,

     

    I hope that you will benefit from this document for execution of web form from BOXI to SDM.

     

    https://support.ca.com/us/knowledge-base-articles.tec495179.html

     

    Thanks and Regards,

    Maheshwar Kusuma



  • 4.  Re: Error to execute web form
    Best Answer

    Broadcom Employee
    Posted 12-15-2017 10:21 AM

    Felipe.........

     

    Please try removing [Public+Folders] from the Resource path and see if that makes a difference.



  • 5.  Re: Error to execute web form

    Broadcom Employee
    Posted 12-15-2017 10:25 AM

    Hey Felipe. 

     

    As Paul and Jerome mentioned, [Public+Folders] is already part of the root path for reports, so you can try removing that. OOTB we just specify the next folder under Public:

     

    For Example:

     

    $BOServerURL?sPath=[CA+Reports],[CA+Service+Management],[CA+Service+Desk],[Change+Order],[Aging]&sDocName=Active+Change+Orders+Aging+by+Priority+for+Categories&sViewer=html

     

    Regards, 

    Brandon Persad



  • 6.  Re: Error to execute web form

    Posted 12-15-2017 11:11 AM

    First of all, I'd like to thank.

     

    I've configured as you guys said, removing the [Public+Folders], but still no working. Appears the same error message.

     

     


    I guess the error is related with some configuration, because when I execute the web form "Overall Summary" ( I guess this web form is OOTB) , the error doesn't occur. See below:

     

     

    Regards,

    Felipe Nunes



  • 7.  Re: Error to execute web form

    Broadcom Employee
    Posted 12-15-2017 11:14 AM

    Felipe........

     

    Please provide a screenshot showing the entire Report Document Library in BOXI Infoview.



  • 8.  Re: Error to execute web form

    Posted 12-15-2017 12:07 PM

    Paul,

     

    Sorry about this question, but where Could I find the Report Document Library in BOXI Infoview?



  • 9.  Re: Error to execute web form

    Broadcom Employee
    Posted 12-15-2017 12:09 PM

    Felipe.......

     

    Login to Infoview and select the Document which shows the report folder structure.

     

    I would like to see how you have the folders setup in CABI.



  • 10.  Re: Error to execute web form

    Posted 12-18-2017 11:42 AM

    Paul,

    Is It this information?

     

     

    Regards,

    Felipe Nunes



  • 11.  Re: Error to execute web form

    Broadcom Employee
    Posted 12-18-2017 12:25 PM

    Yes it is - thanks.

     

    Try placing a copy of the custom report in the OOTB 'CA Reports->CA Service Management->CA Service Desk' folder in Infoview.

     

    Then update the Report Definition within SDM and see if that changes the behavior



  • 12.  Re: Error to execute web form

    Posted 12-18-2017 01:28 PM

    Paul,

     

    The problem was solved.


    We did 2 alters:

    1) remove the caracter "-" from the web form's name

    2) change the report's name to a shorter name.

     

    After that, the web form has worked at report's tab.


    Thank you for support.

    Regards,

    Felipe Nunes



  • 13.  Re: Error to execute web form

    Broadcom Employee
    Posted 12-18-2017 02:25 PM

    Felipe.

     

    That is great news.

     

    Glad everything is working now



  • 14.  Re: Error to execute web form

    Broadcom Employee
    Posted 12-15-2017 11:31 AM

    Have you cleared the webcache? Check if that make any difference!



  • 15.  Re: Error to execute web form

    Posted 12-15-2017 12:05 PM

    Maheshwar,

     

    I've cleared the browser cache and I've run the commad pdm_webcache and it's still not working.