CA Service Management

Expand all | Collapse all

CA SDM Integration Error - USS / Service Catalog

  • 1.  CA SDM Integration Error - USS / Service Catalog

    Posted 04-18-2017 06:40 PM

    Hey guys!

     

    Im trying to integrate the CA Service Catalog and USS with SDM but something is going wrong!

     

    All policys have been set up correctly (i guess), however when i run the setup again to integrate the USS with SDM, for example, an error occurs saying that the SDM policy could not be downloaded.

     

    On USS data source options all the itens of SDM integration has been set up correctly too and, when run the connection test on USS, the connection is executed without any problem.

     

    I verify all policys on SDM and try to generate them again but, still going wrong.

     

    I read some topics on community about some errors and tried to execute some configurations too like, copy the CASM_POLICY file to the %US_HOME%, test the web service URL, generate all the poicys again but nothing solved until now.

     

    Bellow, the error lines of install log of USS:

     

    2017/04/18 18.56.32.329 INFO [DeployThread: Integrando produtos] [ConfigureOSOPWithSDM] Configuring Unified Self-Service with CA Service Desk Manager
    2017/04/18 18.56.32.329 INFO [DeployThread: Integrando produtos] [ConfigureOSOPWithSDM] downloading the certificate File from DB
    2017/04/18 18.56.32.329 ERROR [DeployThread: Integrando produtos] [ConfigureOSOPWithSDM] Caught Exception
    java.lang.NumberFormatException: For input string: ""
    at java.lang.NumberFormatException.forInputString(Unknown Source)
    at java.lang.Long.parseLong(Unknown Source)
    at java.lang.Long.parseLong(Unknown Source)
    at com.ca.smsi.installui.integration.tasks.ConfigureOSOPWithSDM.downloadSDMCertFromDB(ConfigureOSOPWithSDM.java:314)
    at com.ca.smsi.installui.integration.tasks.ConfigureOSOPWithSDM.configureOSOPWithSDMDetails(ConfigureOSOPWithSDM.java:142)
    at com.ca.smsi.installui.integration.tasks.ConfigureOSOPWithSDM.run(ConfigureOSOPWithSDM.java:76)
    at com.ca.smsi.installui.tasks.AutoIntegrateTask.run(AutoIntegrateTask.java:140)
    at com.ca.smsi.wizard.task.Task.start(Task.java:222)
    at com.ca.smsi.installcore.DeployThread.run(DeployThread.java:455)
    2017/04/18 18.56.32.330 ERROR [DeployThread: Integrando produtos] [ConfigureOSOPWithSDM] Download of SDM Policy failed.



  • 2.  Re: CA SDM Integration Error - USS / Service Catalog

    Posted 04-18-2017 09:48 PM

    For the error 'Download of SDM Policy failed.', please check the below:

    *******In CA SDM********

    # Firstly, we need to create the policy through SDM and copy it into the correct folders.

    Use the default Policy code as it is set in the Catalog(SC) UI at

    Service Catalog > Administration > Configuration > CA Service Desk:

    The property named 'Keystore name'

    - Use the correct keystore name and a .P12 file with same name should be present in USMHOME

    - e.g. CASM_POLICY.p12

    The property named 'Policy Code'

    - which is 'CASM_POLICY'. You may wish to use these to simplify.

    # Then Copy the .p12 file into the correct folders

    # Now, set the Service Catalog-properties accordingly.

    ==============================================================================

    Below are the steps to create and configure the policy:

    1. To create the policy in SDM with the name as set in Service Catalog.
    2. Go to the Service Desk UI and login as administrator:
    3. Go to Administration > SOAP Web Service Policy > Policies
    4. When not existing, click 'Create New' button and set the properties:

    - Symbol and Code to CASM_POLICY.

    - Status to Active,

    - Proxy Contact to "Administrator, Service Desk" (whichever userid is scadmin)

    or "System_CASM_Admin" (which userid is CASMAdmin) or any other Service Catalog admin user

    - Allow Impersonate to Yes

    - other settings can be left as default.

    1. Click 'Save'. Click 'Close Window'.
    2. Go to Administration > SOAP Web Service Policy > Policies > Search to verify

     

    Note:

    While creating the webservice policy from service desk administration, the "Has key" field is set by default to "No" and is read only.

    It is not possible to edit it.

    The setting should/will get set to Yes automatically, after you create(d) the policy file itself in the next step.

    You can open the policy in SDM to verify this after you created the .p12 file.

     

    1. Next, we need a certfile to be created for that policy.

    6a. On the Service Desk machine, open the command prompt run 'nxcd' (This command is to go to SDM root folder) and then run this command  "pdm_pki -p CASM_POLICY -f"

    (replacing the policy code name with the custom one if you decided to use one).

    6b. This will create CASM_POLICY.p12 (or equivalent for a custom policy) in that directory i.e %NX_ROOT% folder.

     

    1. Then Copy the .p12 file into the correct folders
    2. You then need to copy it to your Service Catalog machine's %USM_HOME% location/folder.

     

    1. Lastly, set the SC-properties accordingly.
    2. Then, back in the Catalog UI logged-in as 'scadmin' user (admin credential login):
    3. Goto Administration > Configuration > CA Service Desk

    - Set Enable PKI to 'Yes'

    - Ensure that the Keystore Name is set to CASM_POLICY.p12 (case sensitive)

    - Ensure that the Policy Code is set to CASM_POLICY (case sensitive)

    - Ensure that the Port Number is set to the SDM-port number

    - Ensure that the Host Name is set as the 'single' hostname of the SDM-server

     

     

    Now the 'Test' should then successfully use the certfile to connect to Service Desk.

    I hope this helps!

     

    Thanks

    Junaid



  • 3.  Re: CA SDM Integration Error - USS / Service Catalog

    Posted 04-19-2017 11:03 AM

    Hi JunaidBinGhalib!

     

    Many thanx for your help!

     

    I followed the steps that you post here and the integrations are working fine, now.

     

    However, and sorry if im not being so clear (this is the first time there i have to install and configure all components of Service Management), but no one ticket are opened on CA SDM after integrate all components (i guess, again!).

     

    I believe that, logically, I will need run some other configuration so that this really happens, right?

     

    Only the policys configuration and integration between USS and Catalog will no just open a ticket in SDM...

     

    Wel, this is the USS data source options with de SDM, Catalog and Google integrated:

     

     

     So, what i need to do to allow the USS open a ticket on SDM after a new request to be opened? A Macro or something like that?

     

    Many thanx for all the help!!



  • 4.  Re: CA SDM Integration Error - USS / Service Catalog

    Posted 04-19-2017 09:31 PM

    Hi @diegolimabsb

     

    Below is the screenshot for you to cross-verify for the data source against CA Service Desk Manager

     

     

    Once your done with above configuration, go to home>click report an issue> fill in the appropriate fields >click submit > this creates new ticket in the CA SDM.

     

     

    I hope this helps!

    Thanks

    Junaid 



  • 5.  Re: CA SDM Integration Error - USS / Service Catalog

    Broadcom Employee
    Posted 04-24-2017 05:19 AM

    Hi Diego,

    The steps which was shared was it helpful?

    ~Vinod.



  • 6.  Re: CA SDM Integration Error - USS / Service Catalog

    Posted 04-24-2017 10:52 AM

    Hi JunaidBinGhalib!!

     

    Thax again for your help!

     

    For the urgency that I am in this customerI had to open a support case.

     

    But I reviewed all the steps of the integration and after some tests realized that for some reason the USS was not found the file DEFAULT.p12 in the path C: \ Program Files \ CA \ Self Service \ OSOP \ shared \ sdmcert \ 10154

     

    When checking the path of the certificate I also realized that the final folder "10154" did not exist, when I created it the error message changed to the following:

     

    [ServiceMgmtClientServiceDeskImpl: 82] Error while logging in using certificate: failed to decrypt safe contents entry: javax.crypto.BadPaddingException: Given final block not properly padded

     

    At this moment I just generated a new certificate and put it on the path, but still gives the error above.



  • 7.  Re: CA SDM Integration Error - USS / Service Catalog

    Posted 04-24-2017 11:30 AM

    I did some quick searches and it looks like the problem is in the DEFAULT.p12 file, likely to be corrupted or something.

     

    Anyway, as stated in the previous post, I generated a new file with the same name and copied it to the destination folder on USS, but did not work.