DX Application Performance Management

Expand all | Collapse all

Wildfly20 WIly Agent Error

Jump to Best Answer
  • 1.  Wildfly20 WIly Agent Error

    Posted 09-05-2020 03:50 PM
    ​Hi, We recently upgrade from jboss-as-7.1.1.Final to wildfly20. We have agent CA Wily Introscope(R) Version 10.5.2 Release 10.5.2.15 installed which was just working fine with jboss 7. After wildfly20 upgrade we are getting below error. If I disable agent then these errors go away.

    Any idea How to resolve these errors?

    22:01:24,885 ERROR [org.jboss.as.controller.management-operation] (Agent Heartbeat) WFLYCTL0013: Operation ("read-attribute") failed - address: ([
        ("subsystem" => "datasources"),
        ("data-source" => "TestDB")
    ]) - failure description: "WFLYCTL0216: Management resource '[(\"subsystem\" => \"datasources\")]' not found"

    22:01:24,889 ERROR [org.jboss.as.controller.management-operation] (Agent Heartbeat) WFLYCTL0013: Operation ("read-attribute") failed - address: ([
        ("subsystem" => "jca"),
        ("workmanager" => "default"),
        ("short-running-threads" => "default")
    ]) - failure description: "WFLYCTL0216: Management resource '[(\"subsystem\" => \"jca\")]' not found"

    22:01:24,890 ERROR [org.jboss.as.controller.management-operation] (Agent Heartbeat) WFLYCTL0013: Operation ("read-attribute") failed - address: ([
        ("subsystem" => "jca"),
        ("workmanager" => "default"),
        ("short-running-threads" => "default")


  • 2.  RE: Wildfly20 WIly Agent Error
    Best Answer

    Broadcom Employee
    Posted 09-06-2020 10:41 AM
    WildFly 20 is not a supported platform for that version of APM.
    It's not even certified yet with SaaS.
    The best thing you can do is upgrade your EMs to at least 10.7 SP3 or higher and use our SaaS running on compatibility mode to connect to your EM to get the best results.

    I've had good results with monitoring WildFly 19 and all current versions of JBoss EAP with 10.7 and SaaS agents, but I lean heavily towards using SaaS as it's updated faster than 10.7.

    ------------------------------
    Custom Solution Architect
    Broadcom
    ------------------------------



  • 3.  RE: Wildfly20 WIly Agent Error

    Posted 09-08-2020 08:27 AM
    ​Hi, Thanks for your response. If we upgrade just only interscope agent to 10.7 SP3 will that work with other manager modules still being 10.5? Do you have any document or link that you can share which shows the upgrade steps. Thanks


  • 4.  RE: Wildfly20 WIly Agent Error

    Broadcom Employee
    Posted 09-08-2020 11:19 AM
    To clarify: You should upgrade your Enterprise Managers to 10.7SP3 or higher and use our SaaS agents running on compatibility mode so they can send data to your EMs.

    ------------------------------
    Custom Solution Architect
    Broadcom
    ------------------------------



  • 5.  RE: Wildfly20 WIly Agent Error

    Broadcom Employee
    Posted 09-08-2020 11:20 AM
    Structurally, the SaaS agents and on premise agents look the same, so there shouldn't be any changes you will have to make for your dashboards and alerts.

    ------------------------------
    Custom Solution Architect
    Broadcom
    ------------------------------



  • 6.  RE: Wildfly20 WIly Agent Error

    Broadcom Employee
    Posted 09-08-2020 11:35 AM
    I have also mentioned this on a recent post, but 10.5 is scheduled for EOS at the end of the year. You should start planning the upgrade of your agents now if you want continued support from Broadcom.

    https://support.broadcom.com/external/content/release-announcements/CA-APM-Release-and-Support-Lifecycle-Dates/3058

    ------------------------------
    Solution Engineering
    Broadcom
    ------------------------------



  • 7.  RE: Wildfly20 WIly Agent Error

    Posted 09-08-2020 11:53 AM
    ​Thanks for the reply Haruhiko, what is the difference between SaaS agent and on-premises agent?

    Do you have any document pointers URL to upgrade current 10.5 setup ( with multiple Jboss agents and 1 EM - all on-premises ) to upgrade to 10.7? The document will be helpful to get the upgrade processing started on our side. Thanks


  • 8.  RE: Wildfly20 WIly Agent Error

    Broadcom Employee
    Posted 09-08-2020 12:43 PM
    This is the upgrade document to APM 10.7.
    https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/application-performance-management/10-7/upgrading.html