DX Application Performance Management

Expand all | Collapse all

Agent communication over the port 8444

Jump to Best Answer
  • 1.  Agent communication over the port 8444

    Posted 06-18-2020 06:13 AM
    Hi Team,

    I am trying to configure agent communication in port 8444. But getting the error "Failed to connect to the Introscope Enterprise Manager at <hostname of collector>:8444,com.wily.isengard.postofficehub.link.net.DefaultSocketFactory (Read timed out)".

    Does any configuration need to be done form the APM collector side under "IntroscopeEnterpriseManager.properties" ?

    I did curl -vk to APM collector for app server. It says connected successfully on port 8444 to APM collector.

    Please assist.


    Regards
    Amit Bisht

    ------------------------------
    Technical Consultant
    UPS
    ------------------------------


  • 2.  RE: Agent communication over the port 8444
    Best Answer

    Broadcom Employee
    Posted 06-18-2020 06:31 AM
    Hello Amit,
    The error message shows that the agent is making a socket connection (com.wily.isengard.postofficehub.link.net.DefaultSocketFactory). The default port value for sockets on the Enterprise Manager is 5001.

    I assume port 8444 is a HTTPS port on the Enterprise Manager. That port would be configured in em-jetty-config.xml, this configuration has to be activated in IntroscopeEnterpriseManager.properties.

    In that case, you need to specify the HTTPS protocol in the connection string in the agent profile, there is an example already in the profile.
    You would need to change the host from the example of course.

    agentManager.url.1=https://localhost:8444

    Depending on how many agents you need to connect this way - it should be limited to only those that need to connect in this way due to extra performance load on the Enterprise Manager - you need this port to be enabled on both the MOM and collectors - any collectors you want it to connect to.

    If, on the other hand, you want the Enterprise Manager plain socket port to be 8444, you would need to update that in IntroscopeEnterpriseManager.properties

    Assuming you only have one channel updated

    introscope.enterprisemanager.enabled.channels=channel1


    you would change the channel 1 port to 8444

    introscope.enterprisemanager.serversocketfactory.channel1=com.wily.isengard.postofficehub.link.net.server.DefaultServerSocketFactory

    introscope.enterprisemanager.port.channel1=8444


    Many thanks,
    David


  • 3.  RE: Agent communication over the port 8444

    Posted 06-18-2020 08:02 AM
    Edited by Amit Singh Bisht 06-18-2020 08:06 AM
    Hi David,

    I appreciate your quick response.

    We have to use both the port(5001 and 8444) for agent communication. The plan is to use 8444 port for DMZ applications.

    What changes are needed from the APM MOM/Collector side? Attaching jetty and IntroscopeEnterpriseManager.properties for your reference.

    Regards
    Amit Bisht

    ------------------------------
    Technical Consultant
    UPS
    ------------------------------

    Attachment(s)



  • 4.  RE: Agent communication over the port 8444

    Broadcom Employee
    Posted 06-22-2020 09:02 AM
    Hi Amit,
    Please open a support case to analyze further. Or let us know, we can open one for you.
    Thanks,
    Yanna


  • 5.  RE: Agent communication over the port 8444

    Posted 08-27-2020 10:01 PM
    Edited by Raju Malireddy 08-27-2020 10:10 PM
    Hi Amit,

    I have enabled SSL communication between agents to MOM and collecotrs but collectors still communicate with MOM with TCP port 5001, make sure your collectors mentioned as below in your IntroscopeEnterpriseManager.properites. then it will work.

    Collector side:
    introscope.enterprisemanager.clustering.login.em1.host=colletorhostname
    introscope.enterprisemanager.clustering.login.em1.port=5001
    introscope.enterprisemanager.clustering.login.em1.publickey=config/internal/server/EM.public

    Agents side:
    if you are using TCP use port 5001 or if you are using SSL use port 5443 in Introscope agent profile with below string.
    ssl:momservername:5443

    Regards,
    Raju Malireddy.