DX Application Performance Management

Expand all | Collapse all

Unable to monitor any IIS Application using .Net Agent 10.7 SP3

Jump to Best Answer
  • 1.  Unable to monitor any IIS Application using .Net Agent 10.7 SP3

    Posted 08-14-2020 11:09 AM
    I have ​Installed .Net Agent v10.7 SP3 on Windows 2008 R2 using documentation.

    I am able to see metrics from PerfMonCollectorAgent.exe, but nothing from any of the IIS applications.

    Environment Variables:
    com.wily.introscope.agentProfile=F:\Program Files\CA APM\Introscope\wily\IntroscopeAgent.profile
    Cor_Enable_Profiling=0x1
    COR_PROFILER={5F048FC6-251C-4684-8CCA-76047B02AC98}

    Following is the log from one of the application: nativeprofiler_EQCI.log

    Application w3wp.exe is an IIS process
    AppPool "EQCI" monitored
    Module Loaded C:\windows\Microsoft.Net\assembly\GAC_32\mscorlib\v4.0_4.0.0.0__b77a5c561934e089\mscorlib.dll Domain: EE Shared Assembly Repository in Assembly mscorlib[0x904010] [ngen:0]
    Started loading F:\Program Files\CA APM\Introscope\wily\default-typical.pbl
    Started loading F:\Program Files\CA APM\Introscope\wily\toggles-typical.pbd
    Loaded F:\Program Files\CA APM\Introscope\wily\toggles-typical.pbd
    Started loading F:\Program Files\CA APM\Introscope\wily\required.pbd
    Loaded F:\Program Files\CA APM\Introscope\wily\required.pbd
    Started loading F:\Program Files\CA APM\Introscope\wily\dotnet.pbd
    Loaded F:\Program Files\CA APM\Introscope\wily\dotnet.pbd
    Started loading F:\Program Files\CA APM\Introscope\wily\webservices.pbd
    Loaded F:\Program Files\CA APM\Introscope\wily\webservices.pbd
    Started loading F:\Program Files\CA APM\Introscope\wily\MVC.pbd
    Loaded F:\Program Files\CA APM\Introscope\wily\MVC.pbd
    Started loading F:\Program Files\CA APM\Introscope\wily\brtm.pbd
    Loaded F:\Program Files\CA APM\Introscope\wily\brtm.pbd
    Started loading F:\Program Files\CA APM\Introscope\wily\errors.pbd
    Loaded F:\Program Files\CA APM\Introscope\wily\errors.pbd
    Started loading F:\Program Files\CA APM\Introscope\wily\skips.pbd
    Loaded F:\Program Files\CA APM\Introscope\wily\skips.pbd
    Started loading F:\Program Files\CA APM\Introscope\wily\skipsfordi.pbd
    Loaded F:\Program Files\CA APM\Introscope\wily\skipsfordi.pbd
    Loaded F:\Program Files\CA APM\Introscope\wily\default-typical.pbl
    Failed with invalid handle    <<<<<--------------------  All application logs have the folloing 2 lines...
    Hijacked [mscorlib]System.AppDomain::SetupDomain <<<<<--------------------
    Instrumented [mscorlib]System.AppDomain::SetupDomain - 0x0(12)
    Module Loaded C:\windows\Microsoft.Net\assembly\GAC_32\System.Web\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.Web.dll Domain: EE Shared Assembly Repository in Assembly System.Web[0xdaacd8] [ngen:0]
    Instrumented [System.Web]System.Web.Hosting.ProcessHostFactoryHelper::.ctor - 0x0(12)
    Module Loaded C:\windows\assembly\GAC_MSIL\wily.Agent\10.7.0.197__2b41fdfb6cd662a5\wily.Agent.dll Domain: EE Shared Assembly Repository in Assembly wily.Agent[0xeaab68] [ngen:0]
    Module Loaded C:\windows\SysNative\CrowdStrike.Sensor.ScriptControl11604.dll Domain: DefaultDomain in Assembly CrowdStrike.Sensor.ScriptControl[0xb266d4] [ngen:0]


  • 2.  RE: Unable to monitor any IIS Application using .Net Agent 10.7 SP3

    Broadcom Employee
    Posted 08-24-2020 09:59 AM
    Hi Muneer,

    Could you try using agent filter properties, and see?

    Agent filters are on the IntroscopeAgent.profile

    For an exp:
    introscope.agent.dotnet.agentfilter.enabled=true
    introscope.agent.dotnet.agentfilter.pattern.excludes=AppPool Name
    #
    introscope.agent.dotnet.agentfilter.pattern.includes=*.*

    Thanks,
    Yanna


  • 3.  RE: Unable to monitor any IIS Application using .Net Agent 10.7 SP3

    Posted 08-25-2020 06:48 AM
    It seems the server has an issue with the configuration of the CLRs.

    Thanks for your attention.

    Regards,

    Muneer Jaber


  • 4.  RE: Unable to monitor any IIS Application using .Net Agent 10.7 SP3

    Broadcom Employee
    Posted 08-25-2020 10:11 AM
    Check to make sure Agent DLL is listed/registered in GAC

    ------------------------------
    Custom Solution Architect
    Broadcom
    ------------------------------



  • 5.  RE: Unable to monitor any IIS Application using .Net Agent 10.7 SP3
    Best Answer

    Broadcom Employee
    Posted 08-27-2020 04:14 PM
    Please check if following help you.
    Verify the .NET Agent Installation
    https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/application-performance-management/10-7/implementing-agents/microsoft-net-agent/install-the-net-agent.html#concept.dita_e53a939f3231d9a5283f5714a9efc84b006de3ac_VerifytheNETAgentInstallation
    Troubleshooting and Tips for the .NET Agent
    https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/application-performance-management/10-7/implementing-agents/microsoft-net-agent/troubleshooting-and-tips-for-the-net-agent.html