DX Application Performance Management

 View Only
  • 1.  Instrumented App doesn't send data to CA AXA

    Posted Mar 27, 2018 12:41 PM
      |   view attached


    I installed CA AXA (single node installation), installation script reported no errors, but I couldn't access admin console.

    I followed the recommendations in the troubleshooting section - https://docops.ca.com/ca-app-experience-analytics/17-2/en/installing-and-upgrading/ca-app-experience-analytics-installation/troubleshooting-the-installation#TroubleshootingtheInstallation-UnabletoLogintotheAdministrationConsoleorSendDatafromtheInstrumentedApplication


    It solved the problem of login into admin console, but the data from instrumented app is still not getting into AXA.

    When I'm looking at the app (in Manage Apps) - I see the notification:

    The following Apps aren't sending data to CA App Experience Analytics:


    Any ideas? 


    Thanks in advance,


  • 2.  Re: Instrumented App doesn't send data to CA AXA

    Broadcom Employee
    Posted Mar 27, 2018 01:55 PM

    Do you have access to device logging from the app sending data? If so, the AXA sdk should log a network response from the attempt to send data from your app to the collector on the AXA side. Feel free to open a support case if you need assistance with this. 

  • 3.  Re: Instrumented App doesn't send data to CA AXA
    Best Answer

    Posted Mar 28, 2018 05:51 AM

    Thought it will be helpful to share this here:

    after further troubleshooting, I've identified that one of the SQL statements in step 2 is the breaking change - 

    update ARCMNCONFIG set paramvalue='http://maa-vm.ca.com:8080/mdo/collector/v2' where paramname like '%MDO.CollectorURL%';

    instead of changing the param value to the value provided, I just changed the <host> portion to FQDN of that host, leaving the port and the path unchanged. In addition, there are two different parameters - MDO.CollectorURL and MDO.CollectorURL.Internal, I only changed MDO.CollectorURL, leaving MDO.CollectorURL.Internal pointing to localhost.
    It's working now, although not all the metrics are being collected - but it's another issue - I'll start another thread.