DX Application Performance Management

Expand all | Collapse all

Cannot view SOA Services on Introscope

  • 1.  Cannot view SOA Services on Introscope

    Posted 05-27-2015 11:07 AM

    I have enabled SOA Performance Module by copying all jar files under SOAPerformanceModule from location wily_home/examples to wily_home/core/ext. Also I have included spm.pbl which contains required PBD files into the profile file.

     

    But after restarting the Fuse, I couldn't view the Webservice node on Introscope.

     

    Need Help. What else should be done ?



  • 2.  Re: Cannot view SOA Services on Introscope

    Posted 05-27-2015 11:09 AM

    I am using wily.9.5.5.0 version.



  • 3.  Re: Cannot view SOA Services on Introscope

    Posted 05-27-2015 11:31 AM

    Hi,

    This depends what web services are actually being used, since you mention Fuse, I think it has its own web services that we don't support directly out of the box.

    In which case you might need to apply the extra files in this add-on;

    SOAP WebServices Addon

     

    I'm not sure what you specifically copied to the /core/ext folder but SPM only relies on WebServicesAgent.jar and BoundaryOnlyTrace.jar

     

    Thanks,

    David



  • 4.  Re: Cannot view SOA Services on Introscope

    Posted 05-27-2015 06:26 PM

    Hi,

    We are using SOA Performance Monitoring for Fuse services. Does'nt the instrumentation provided directly with wily support Fuse services ?

     

    Can this be achieved by using the addon you mentioned above ? Shall we include the jars in the same folder (wily_home/core/ext) ?

     

    Please let me know the steps.



  • 5.  Re: Cannot view SOA Services on Introscope

    Posted 05-28-2015 11:21 AM

    Also do we need to do any changes to the EM ?



  • 6.  Re: Cannot view SOA Services on Introscope

    Posted 06-01-2015 08:53 AM

    Hi,

    I have copied all the PBDs nd PBL in config file and jar at wily/core/ext.

    But still no success..

    I cannot see the Webservice node.



  • 7.  Re: Cannot view SOA Services on Introscope

    Posted 08-03-2015 02:58 PM

    Hi:

    I am marking this as assumed answered you did not request a follow-up over some time. Please open a new question with new information if needing additional assistance

      

      

    Thanks

    Hal German

    APM Support