Service Virtualization

Expand all | Collapse all

JAVA virtual service is not responding if connection is dropped

Jump to Best Answer
  • 1.  JAVA virtual service is not responding if connection is dropped

    Posted 10-18-2017 06:09 PM

    Hi,

     

    I am having a JAVA virtual service which is deployed in VSE. I am connecting to the server via agent from my local weblogic server. If the connection is lost between my local and VSE server OR if I update the JAVA virtual service and re-deploy, then though the connection is established we are not getting any response.

     

    If we try to deploy JAVA service multiple times, then the service is deleted automatically and we are getting below error while deploying.

     

    Connection drop log in local console:

    [DevTest AGENT:A][WARN][10100][148][pool-12-thread-1][10/18 13:45:06 (769)] Connection to Agent broker at ssl://xxxxx.unix.gsm1900.org:2009?daemon=true was dropped...
    [DevTest AGENT:A][WARN][10100][28][Stats Gathering Thread][10/18 13:45:06 (769)] Connection to Agent broker at ssl://xxxxx.unix.gsm1900.org:2009?daemon=true was dropped...

     

    java.rmi.RemoteException: Timeout (45,000 ms, actual wait 45,006 ms) on server object ssl://xxxxxxx:2013/VSE on method addService
    at com.itko.lisa.net.Transactor.transact(Transactor.java:109)
    at com.itko.lisa.net.ClientBase.transact(ClientBase.java:358)
    at com.itko.lisa.net.ClientBase.invokeMethod(ClientBase.java:271)
    at com.itko.lisa.net.VSEClient.addService(VSEClient.java:103)
    at com.itko.lisa.vse.ui.actions.DeployToVSEAction$1.doCallback(DeployToVSEAction.java:155)
    at com.itko.util.swing.panels.ProcessingDialog$2.run(ProcessingDialog.java:194)
    at java.lang.Thread.run(Unknown Source)

     

    If we try to deploy from the web console, then below error is being displayed.

    Error: Unable to deploy the virtual service. The server responded with: Our audit file is either missing or we are not a model archive or are corrupt.



  • 2.  Re: JAVA virtual service is not responding if connection is dropped
    Best Answer

    Posted 10-19-2017 12:36 AM

    This sounds like an issue in the product. You should open a ticket with support at support.ca.com.



  • 3.  Re: JAVA virtual service is not responding if connection is dropped

    Posted 10-19-2017 06:51 PM

    No access to create ticket.Thanks for the update William.