Release Automation

Expand all | Collapse all

Upgrade Release Automation from version 6.2

  • 1.  Upgrade Release Automation from version 6.2

    Posted 09-02-2020 02:50 PM


    ------------------------------
    Telecom Argentina
    ------------------------------


  • 2.  RE: Upgrade Release Automation from version 6.2

    Posted 09-09-2020 05:05 AM
    Hello

    You have a do an in-place upgrade. Your OS and hardware are still good and supported. During the upgrade, the previous release is saved in the same FileSystem, so monitor the used space.
    The upgrade path is:
    - Upgrade NAC & NES to 6.3
    - Upgrade Agents to 6.3
    - Upgrade NAC & NES to 6.6
    - Upgrade NAC & NES to 6.7
    - install patch 6.7 b124  (6.7.1)
    - Upgrade agents to 6.7.1

    6.3, 6.6 and 6.7 are available on casupport.broadcom.com.

    If you want to change server and DB, then you must first install 6.2.0.3029 on the new platforms, make a DB export/import and run the upgrade steps. Then you can copy Nexus repo artifact folders.

    Regards


  • 3.  RE: Upgrade Release Automation from version 6.2

    Posted 09-21-2020 03:20 PM

    Thanks for your answer.

    Is it mandatory to update agents?

    6.2 agents are not supported?



    ------------------------------
    Telecom Argentina
    ------------------------------



  • 4.  RE: Upgrade Release Automation from version 6.2

    Posted 09-22-2020 03:32 AM
    Hello

    I am modifying my first answer, as i have just completed a 6.1 to 6.7 upgrade. You can skip 6.3. The path is:
    - Upgrade NAC & NES to 6.6
    - Upgrade NAC & NES to 6.7
    - install patch 6.7 b124  (6.7.1)
    - Upgrade agents to 6.7.1

    Agents 6.2 will work well with NAC/NAES 6.6. You may have issues with 6.7, it depends on the actions you use.
    You can upgrade Agent 6.2 to 6.6 from 6.6 ROC.  But Broadcom support told me that upgrading 6.2 agents from 6.7 ROC is not supported and may fail.

    Regards


  • 5.  RE: Upgrade Release Automation from version 6.2

    Broadcom Employee
    Posted 09-22-2020 10:23 AM
    Hi Javier,
    I hope this message finds you well. The 6.2 agents are not supported. If you had a problem with/on a 6.2 agent then you would need to upgrade to a supported version before help could be provided. But the system itself is capable working with older/unsupported agents. This should give you time to get the agents upgraded without rushing to do so.

    I hope this helps.
    Kind regards,
    Gregg


  • 6.  RE: Upgrade Release Automation from version 6.2

    Broadcom Employee
    Posted 09-22-2020 10:30 AM
    And in case you haven't completed the NAC/NES upgrade yet, here are some upgrade best practices KB articles that may help:
    6.6 Upgrade Best Practices
    Best Practices Guide prior to Release Automation upgrade
    Upgrading the NAC fails with error "Checking for running jobs..Active jobs were found, Please stop all active jobs and continue the upgrade process"

    Cheers,
    Gregg