Release Automation

Expand all | Collapse all

What could be the reason why some deploys do not appear in a report?

Jump to Best Answer
  • 1.  What could be the reason why some deploys do not appear in a report?

    Posted 09-14-2018 05:56 PM

    In the dashboard I can see a succeeded deploy from aplication GLE in environment PROD

     

     

    But in the deployment by environment report that succeded deploy doesn't exists

     

     

    I chose all the environments and all the processes of the application

     

     

    We make statistics and metrics based on that report and now it seems that it was not reliable.

    What could be the reason why some deploys do not appear?



  • 2.  Re: What could be the reason why some deploys do not appear in a report?
    Best Answer

    Posted 09-18-2018 02:56 AM

    Hi,

     

    I checked the behavior in house, but I could not reproduce your situation which succeeded deployment was counted as failure.

    However, the counter of both success/fail was reset when the deployment was failed, despite only succeeded deployments can be counted properly.  I guessed the counter is missing if deployment is duplicated with same application, process and environment.

    So, I think it is unexpected behavior.

    I recommend to open a support case to investigate further.

     

    On the other hand, I'm not sure, but you may be able to find the expected data in statistics_counters table in database as work around. 

     

    Thanks

    Yas