Release Automation

Expand all | Collapse all

Failed to distribute artifact

Jump to Best Answer
  • 1.  Failed to distribute artifact

    Posted 02-16-2015 01:21 AM

    While running Nolio process we are getting following error, we tried various option however process is not moving ahead of step from artifact distribution method.

     

    Failed to distribute artifact [artifact_store/releaseId_2371/Release Configuration/Release Configuration/15.1/maniFest.xml] to execution server

     

    Please can you advice most possible root cause of problem.



  • 2.  Re: Failed to distribute artifact

    Posted 02-17-2015 08:29 AM

    The main issue is probably that the artifact is not available to RA.

     

    In "Artifact Management" under the artifact definition where you have "maniFest.xml" defines, try to select "Store artifact in local repository" under "Edit Artifact" Save and refresh the artifact definition page - if the artifact is not available, this will be shown in the "Edit artifact" page as an error message. - once stored in RA repository, there will be a small tick in the "In Repository" field.

    If this is the case, then there is an issue with either the way the artifact is retrieved, or the agent selected, is not able to get the artifact.



  • 3.  Re: Failed to distribute artifact
    Best Answer

    Posted 02-23-2015 12:58 AM

    It seems issue with environment configuration.

     

    When nolio server and NES reside on both box then due to some issue NES was not working. As Nolio was not able to distribute artifact on same host which was also acting as NES.

     

    Finally we changed NES for all agents to work it correctly.