Clarity PPM1

Expand all | Collapse all

XOG and JRE

Jump to Best Answer
  • 1.  XOG and JRE

    Posted 09-11-2019 12:18 AM
    We recently upgraded to Clarity PPM, and to be certain that I had all of my client software to the latest versions, I re-downloaded and installed XOG.

    I am unfortunately now receiving the following notification when I try to run the XOG client app:

    "Exception in thread "main" java.lang.UnsupportedClassVersionError: com/niku/xog/client/XOGClient has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0"

    I am running a Windows 10 PC, with Java version 8 Update 221 (build 1.8.0_221-b11).

    Could anyone tell me whether this is an issue with the version of JRE I am running and how I might resolve this?

    Thanks,
    Will


  • 2.  RE: XOG and JRE

    Posted 09-11-2019 05:53 AM
    What was the clarity version you upgraded, it looks like local Java also needs to be upgraded

    ------------------------------
    Thanks & Regards
    Suman Pramanik
    Principal Support Engineer | Customer Success & Support, Enterprise Software Division
    Broadcom
    ------------------------------



  • 3.  RE: XOG and JRE

    Posted 09-11-2019 09:51 AM
    Hi Suman,

    I forgot to include that detail - we're on 15.6.1.


  • 4.  RE: XOG and JRE

    Posted 09-11-2019 09:52 AM
    15.6.1 supports java 11 and i see you are using Java 1.8, hence you would need to upgrade Java and test it out

    ------------------------------
    Thanks & Regards
    Suman Pramanik
    Principal Support Engineer | Customer Success & Support, Enterprise Software Division
    Broadcom
    ------------------------------



  • 5.  RE: XOG and JRE

    Posted 09-11-2019 10:40 AM
    I may be glaring at the wrong page, but https://www.java.com/en/download/win10.jsp seems to offer version 8 (1.8) as the most recent version. I think I'm missing something that may be obvious to others.


  • 6.  RE: XOG and JRE
    Best Answer

    Posted 09-12-2019 01:45 AM
    I messed around with downloading and installing the JDK (v12) and the JRE (1.8.2-221) with no luck. It was only when I located and installed an older version of XOG that I was finally able to make it work. I made certain to restart my workstation after each uninstall and re-install, so it wasn't a matter of my computer remembering previous Java versions.
    Glad that I managed to work it out.


  • 7.  RE: XOG and JRE

    Posted 09-12-2019 08:14 AM
    Great to hear.

    ------------------------------
    Thanks & Regards
    Suman Pramanik
    Principal Support Engineer | Customer Success & Support, Enterprise Software Division
    Broadcom
    ------------------------------



  • 8.  RE: XOG and JRE

    Posted 09-12-2019 12:02 PM
    Sounds like you are OK'ing use of XOG from a different version that what the accessed Clarity is?


  • 9.  RE: XOG and JRE

    Posted 09-12-2019 12:35 PM
    Hi Martti,

    I'm not sure if yours is a question or a comment.

    The search for the right match between the JRE version and XOG version was to try to resolve issues in the Class libraries and such. The specific task I was trying to complete was simply some updated to the cmn_users, so they're (likely) the same/compatible xml files between the versions of XOG. If I were to have a need to perform updates on tables that were new/altered from 15.5.1 to 15.6.1, I guess I'd have to have a deeper dig and compare of the sample XML files included with the XOG install.

    Cheers,
    Will