Clarity PPM1

Expand all | Collapse all

Invalid DB objects during Upgrade

Jump to Best Answer
  • 1.  Invalid DB objects during Upgrade

    Posted 25 days ago
    Hi team,

    We are in the process of upgrading our test system from 15.4 to 15.6.1

    After the checkinstall, I noticed two invalid DB objects which I am not able to compile.
    ALTER TYPE SYS_PLSQL_636300_89_1 COMPILE;
    ALTER TYPE SYS_PLSQL_21530_89_1 COMPILE;

    Also when i run db analyze and db compile , I get this:


    Command: compile
    WARNING: An illegal reflective access operation has occurred
    WARNING: Illegal reflective access by org.logicalcobwebs.cglib.core.ReflectUtils (file:/opt/ca/clarity/lib/proxool.jar) to method java.lang.ClassLoader.defineClass(byte[],int,int)
    WARNING: Please consider reporting this to the maintainers of org.logicalcobwebs.cglib.core.ReflectUtils
    WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
    WARNING: All illegal access operations will be denied in a future release
    Compiling the database....
    Following object(s) are invalid:
    SYS_PLSQL_636300_89_1
    SYS_PLSQL_21530_89_1


    Could you please help me here to solve DB compilation issue.

    Regards,
    Divya


  • 2.  RE: Invalid DB objects during Upgrade
    Best Answer

    Posted 25 days ago
    Hi Divya

    You may refer to this KB to fix the problem https://ca-broadcom.wolkenservicedesk.com/external/article?articleId=37710

    ------------------------------
    Thanks & Regards
    Suman Pramanik
    Sr. Principal Support Engineer | Customer Success & Support, Enterprise Software Division
    Broadcom
    ------------------------------



  • 3.  RE: Invalid DB objects during Upgrade

    Posted 25 days ago
    Thanks Suman. That worked.


  • 4.  RE: Invalid DB objects during Upgrade

    Posted 25 days ago
    Great. I see you are upgrading to 15.6.1 and we have 15.7 available. Any reason of staying back in 15.6.1

    ------------------------------
    Thanks & Regards
    Suman Pramanik
    Sr. Principal Support Engineer | Customer Success & Support, Enterprise Software Division
    Broadcom
    ------------------------------



  • 5.  RE: Invalid DB objects during Upgrade

    Posted 25 days ago
    One more question, Can I ignore those warnings?

    Command: compile
    WARNING: An illegal reflective access operation has occurred
    WARNING: Illegal reflective access by org.logicalcobwebs.cglib.core.ReflectUtils (file:/opt/ca/clarity/lib/proxool.jar) to method java.lang.ClassLoader.defineClass(byte[],int,int)
    WARNING: Please consider reporting this to the maintainers of org.logicalcobwebs.cglib.core.ReflectUtils
    WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
    WARNING: All illegal access operations will be denied in a future release


  • 6.  RE: Invalid DB objects during Upgrade

    Posted 25 days ago
    This can be ignored

    ------------------------------
    Thanks & Regards
    Suman Pramanik
    Sr. Principal Support Engineer | Customer Success & Support, Enterprise Software Division
    Broadcom
    ------------------------------