Clarity

Expand all | Collapse all

Routine does not conclude

  • 1.  Routine does not conclude

    Posted 03-27-2019 11:31 AM

    Dear, I can not execute the routines immediately and even when I do the programming, it does not execute either.

     


    Anyone know what can be happening?

     

     

    error found in BG-SYSTEM.LOG:

     

    java.lang.NullPointerException
    2019/03/26 16:37:28.782 | ERROR 26-03 19:37:28,779 -
    2019/03/26 16:37:28.782 | java.lang.NullPointerException
    2019/03/26 16:37:28.782 |
    at com.niku.union.config.TenantConfigurationManager.getValidLocalTenant(TenantConfigurationManager.java:349)
    2019/03/26 16:37:28.783 |at com.niku.union.config.TenantConfigurationManager.getTenantForBgService(TenantConfigurationManager.java:2730)
    2019/03/26 16:37:28.783 | at com.niku.union.bgp.NikuBGServer.startServer(NikuBGServer.java:122)
    2019/03/26 16:37:28.783 | at com.niku.union.bgp.NikuBGServer.initServer(NikuBGServer.java:103)
    2019/03/26 16:37:28.783 | at com.niku.union.bgp.NikuBGServer.main(NikuBGServer.java:304)
    2019/03/26 16:37:28.783 | at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    2019/03/26 16:37:28.783 | at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    2019/03/26 16:37:28.783 | at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    2019/03/26 16:37:28.783 | at java.lang.reflect.Method.invoke(Method.java:497)
    2019/03/26 16:37:28.783 | at org.tanukisoftware.wrapper.WrapperSimpleApp.run(WrapperSimpleApp.java:290)
    2019/03/26 16:37:28.783 | at java.lang.Thread.run(Thread.java:745) 2019/03/26 16:37:28.783 |
    ERROR 2019-03-26 19:37:28,779 [WrapperSimpleAppMain] bgp.JobLogger
    2019/03/26 16:37:28.783 | java.lang.NullPointerException
    2019/03/26 16:37:28.783 | at com.niku.union.config.TenantConfigurationManager.getValidLocalTenant(TenantConfigurationManager.java:349)
    2019/03/26 16:37:28.783 | at com.niku.union.config.TenantConfigurationManager.getTenantForBgService(TenantConfigurationManager.java:2730)
    2019/03/26 16:37:28.783 | at com.niku.union.bgp.NikuBGServer.startServer(NikuBGServer.java:122)
    2019/03/26 16:37:28.783 | at com.niku.union.bgp.NikuBGServer.initServer(NikuBGServer.java:103)
    2019/03/26 16:37:28.783 | at com.niku.union.bgp.NikuBGServer.main(NikuBGServer.java:304)
    2019/03/26 16:37:28.783 | at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    2019/03/26 16:37:28.783 | at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    2019/03/26 16:37:28.783 | at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    2019/03/26 16:37:28.783 | at java.lang.reflect.Method.invoke(Method.java:497)
    2019/03/26 16:37:28.783 | at org.tanukisoftware.wrapper.WrapperSimpleApp.run(WrapperSimpleApp.java:290)
    2019/03/26 16:37:28.783 | at java.lang.Thread.run(Thread.java:745)



  • 2.  Re: Routine does not conclude

    Broadcom Employee
    Posted 03-27-2019 12:17 PM

    This looks like loggers wer corrupted. When did this happen and what was changed 



  • 3.  Re: Routine does not conclude

    Posted 03-27-2019 12:46 PM

    I've been facing this problem for a long time.

     

    I can not get an automatic schedule on the gantt. I can not perform immediate or scheduled routines. The other components of the application are working!



  • 4.  Re: Routine does not conclude

    Broadcom Employee
    Posted 03-27-2019 01:25 PM

    Thanks, this looks like app folder some files must be corrupted or missing. Could you please reset the logger by going to Security.logs URL and reset it and if you continue to see after that then you may need to install the app and point to the database.

     

    If you need additional help, please log a support case and we can help you.



  • 5.  Re: Routine does not conclude

    Posted 03-27-2019 01:47 PM


    You could detail ? I'm new to CA PPM, thank you.



  • 6.  Re: Routine does not conclude

    Broadcom Employee
    Posted 03-27-2019 07:54 PM

    Hi Marcelo

     

    Try resetting your logger.xml as described here:

    PPM Log files such as app-ca.logs are not being up - CA Knowledge 

    Solution 1

    See if that works for you -Nika