Clarity PPM1

Expand all | Collapse all

Error 500 - Internal Server Error pops up, when a attribute value is selected in CA PPM.

  • 1.  Error 500 - Internal Server Error pops up, when a attribute value is selected in CA PPM.

     
    Posted 07-12-2018 04:59 AM

    #clarityerror  Error 500 - Internal Server Error pops up, when a attribute value is selected in CA PPM.

    Description of Issue:

    Two custom attributes Category and Sub Category are configured in edit layout of Change Request page.

    The values in 'Sub Category' are dependent on the selection of value in 'Category'.

     

    Custom attribute 'Category' is associated to a dynamic lookup .This dynamic lookup in its query brings the values from a 'Static Dependent List lookup' fetching the 'Level 1' values.

    There is another attribute 'Sub Category' which fetches the 'Level 2' values from same 'Static Dependent List' and has Parameter Mapping of 'Category' attribute.

     

    When the value of 'Category' field is selected , the page displays error.

     

    Here are the things that I have tried , but did not resolve the issue.

    • Restarting the services
    • Deleting and creating the related lookups and attributes again.
    • Checking the logs for cause
    • Configured the attributes in Create layout(where they worked fine, but Error comes up in Edit layout ) .

     

    CA PPM Version/Build: 15.4.1

     

    Regards,

     

    Sruthi



  • 2.  Re: Error 500 - Internal Server Error pops up, when a attribute value is selected in CA PPM.

    Posted 07-12-2018 05:13 AM

    Hi Sruthi,

     

    I have encountered similar problem in 15.4.1

    In my case, if some Japanese character is placed in page, the problem will occur.

     

    If I changed Display Type of lookup from Pull-Down to Browse, the problem seems to be resolved.

    It maybe 15.4.1 problem.

     

    Regards,

    Shoichi



  • 3.  Re: Error 500 - Internal Server Error pops up, when a attribute value is selected in CA PPM.

    Posted 07-12-2018 08:20 AM

    HI Shoichi, I would recommend opening a case with CA Support for this if you have not done so yet.  This way a proper defect can be logged with engineering/development for it and it can be corrected in a future release.

    Thanks,

    Jon I.



  • 4.  Re: Error 500 - Internal Server Error pops up, when a attribute value is selected in CA PPM.

    Posted 07-13-2018 03:27 AM

    Hi,

     

    The case was already opened and also DE42277.

     

    Regards,

    Shoichi



  • 5.  Re: Error 500 - Internal Server Error pops up, when a attribute value is selected in CA PPM.

    Posted 09-27-2018 10:39 AM

    Hi Shoichi_Sugawara. Do you know if problem has been resolved? I have the same problem in same version (15.4.1). Changing lookup type from pull down to browse solves the problem but pull down has a better look .

    Thanks

    Stefano



  • 6.  Re: Error 500 - Internal Server Error pops up, when a attribute value is selected in CA PPM.

     
    Posted 10-16-2018 07:30 AM

    I think you will have to go with Browse Type only.



  • 7.  Re: Error 500 - Internal Server Error pops up, when a attribute value is selected in CA PPM.

    Posted 08-01-2018 03:53 AM

    Are you using IE as your browser?  We stopped using IE with V15.4.1 as we were getting similar error messages.  Firefox/Chrome works fine.  There will be a patch to be released later this month we have been told to resolve our IE challenge.