Clarity PPM1

Expand all | Collapse all

Not able to save project in OWB(open work bench)

Jump to Best Answer
  • 1.  Not able to save project in OWB(open work bench)

    Posted 11-01-2017 10:22 PM


    There is an issue in saving one of our biggest project in OWB. We are getting a dialog box saying that "server returned HTTP response code 502 for url".

    The project have 10 child projects. The main project have around 200+ resources and 400+ tasks and many number of assignments and baselines.
    Like that each and every child project also have more or less of numbers figures mentioned above. Opening the project in Workbench is also taking time.

    We have checked the “Only Export Current Baselines when opening Investments in a Scheduler” option in project management settings, but still we are not able to save our changes through the OWB.

    Could anyone please let me know, how we can resolve this?

    Thanks,
    Agin A Vadath



  • 2.  Re: Not able to save project in OWB(open work bench)

    Posted 11-02-2017 08:57 AM

    Hi Agin. Are you proxying through a load balancer?

    HTTP Error 502 Bad gateway Explained 



  • 3.  Re: Not able to save project in OWB(open work bench)

    Posted 11-13-2017 12:29 PM

    Yes Robert. we are using load balancer. issue seems to be with a specific project which is having many sub projects associated with it.

     

    If we open each individual sub project, this issue doesn't occur.

     

    Thanks,

    Agin



  • 4.  Re: Not able to save project in OWB(open work bench)

    Posted 11-06-2017 04:13 AM

    Hi Agin, 

     

    Have you tried to to extend your Java Memory limit to see if that helps you to open and save the project via OWB? 

    This is something that is very much machine specific. So you extend the Java Memory for OWB in one machine, and you can expect the result only in that machine. 

     

    Thanks,

    Abhisek Dhar



  • 5.  Re: Not able to save project in OWB(open work bench)
    Best Answer

    Posted 11-06-2017 04:15 AM

    Steps for setting maximum memory usage for Open Workbench:

    1. Start > Run, type in 'regedit' and click OK
    2. Drill down to

      on 32 bits Windows OS such as XP: HKEY_LOCAL_MACHINE\SOFTWARE\Niku\Niku Workbench folder
      on 64 bits Windows OS such as Win7: HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Niku\Niku Workbench

    3. Right click and select New > DWORD value
    4. Enter 'JavaMemoryLimit'
    5. Double-click 'JavaMemoryLimit'
    6. Select Base Decimal
    7. Enter a value in the Value Data field
    8. Click OK and exit the registry

    Important:

    • When adding the new value 'JavaMemoryLimit' it should be created as a DWORD and the unit is in megabytes. Thus a decimal value of 256 would allow allocation of up to 256MB.
    • When setting 'JavaMemoryLimit' the user would usually want to change the Base to be Decimal (not Hexadecimal) when setting the value.
    • If a user sets 'JavaMemoryLimit' to a value that cannot be honored then you may see Workbench start up (flash) and immediately shutdown.

     

     

     

    Thanks,

    Abhisek Dhar



  • 6.  Re: Not able to save project in OWB(open work bench)

    Posted 11-13-2017 12:35 PM

    Thanks Abhisek for the detailed steps. I will test this scenario and will update you by tomorrow.

     

    Thanks,

    Agin



  • 7.  Re: Not able to save project in OWB(open work bench)

    Posted 11-14-2017 08:00 AM

    Hi Agin, 

     

    Did you get a chance to increase the java memory limit of OWB and see if you are still getting the problem?

     

    Thanks,

    Abhisek Dhar