Clarity

Expand all | Collapse all

How to fix 'No matching records found' in Advanced Reporting?

Jump to Best Answer
  • 1.  How to fix 'No matching records found' in Advanced Reporting?

    Posted 03-30-2017 03:25 AM

    Steps we have done:

    • Exported organization from Jaspersoft test environment and imported it to this, production environment
    • After that we could access Advanced Reporting from production environment (application), but when we run the report NULL error appeared.
    • Executed following command in command prompt: admin jaspersoft syncPPMContext -€“userName superuser -password superuser
    • run jobs in following order 'Create and Update Jaspersoft Users', 'Load Data Warehouse', 'Load Data Warehouse Access Rights.'
    • now, when we run a report, 'No matching records were found.' message appeares.
    • In Administration -> System Options there are 'Store Weekly Time Increments?', 'Store monthly Time Increments?', 'Store Fiscal Time Increments?' and 'One Set of Fiscal Periods?' are checked.
    • We have run 'Update Resports Table', 'Load Data Warehouse' and 'Load Data Warehouse Access Rights' jobs. Still the same message in reports - 'No matching records found.'
    • Also, time periods are missing in filter on 'Missing Time' report

    We are using PPM 14.4. patch 5, and Jaspersoft 6.2.1, patch 5.2.1



  • 2.  Re: How to fix 'No matching records found' in Advanced Reporting?

    Broadcom Employee
    Posted 03-30-2017 02:54 PM

    Hi Mateja,

     

    Sounds like everything is configured well, and the reports simply do not return results.

     

    Which reports did you check? Please specify. What happens if you try a different one, for example Resource Capacity vs Allocation?

     

    Also, do the input controls on the left populate for you? Do you have full permissions, including the CSK ones in Jaspersoft?

     

    If the time periods are missing, check your Time Reporting periods - the open ones - do they cover at least several past periods and several future periods?

     

    Lastly, confirm if you're on MSSQL or Oracle.

     

    Thank you -Nika



  • 3.  Re: How to fix 'No matching records found' in Advanced Reporting?

    Posted 03-31-2017 03:29 PM

    I'm also interested in the outcome.  I have a customer that is experiencing same issue. 



  • 4.  Re: How to fix 'No matching records found' in Advanced Reporting?

    Posted 03-30-2017 05:19 PM

    Hello Nika,

    we checked 'Capacity vs. Demand by Role', 'Capacity vs. Allocation by OBS', 'Missing Time' and 'Timesheet Overview.' 'Resource Allocations and Assignments' report also says 'No matching records were found.'

     

    On the left, OBS Unit are shown in the list, bot nothing else can can be populated. Administrator is in role CSK_REPORTS_ALL_DOMAINS.

     

    Yes, we have opene Time Reporting Periods from 27th of February, until January 2018.

     

    MSSQL.

     

    Thank you,

    Mateja



  • 5.  Re: How to fix 'No matching records found' in Advanced Reporting?

    Posted 03-30-2017 05:52 PM

    We have added all CSK rights and now all the filters in reports can be populated. Reports are still displaying 'No matshing records...' and Time Periods are not displayed.



  • 6.  Re: How to fix 'No matching records found' in Advanced Reporting?
    Best Answer

    Broadcom Employee
    Posted 03-30-2017 05:57 PM

    Hi Mateja,

     

    Please check the app time/date and compare to database time/date. They should match, and ideally to the second. If you have more than 5-10 sec difference, reset the time on either of the servers and run a DWH Full Load again.

    Please let me know how it goes.

     

    Kind Regards -Nika



  • 7.  Re: How to fix 'No matching records found' in Advanced Reporting?

    Posted 04-03-2017 07:06 AM

    Hello Nika,

    after they synchronized time between application and database servers, all reports started working correctly!

    Thank you for your help!

     

    Regards,

    Mateja



  • 8.  Re: How to fix 'No matching records found' in Advanced Reporting?

    Posted 04-01-2017 02:40 AM

    Hi Nika,

     

    we have added all CSK rights in Jaspersoft, and all the rights in PPM to admin, and after running 'Load DWH Access Rights' we can now populate all the report filters. Some reports also started to work ('Investment Allocations and Assignments') but all the Capacity ones, when we filter for 2017, don't work.

    We realised that in 'Missing Time' report in Time Period filter, there are only periods from January 2016 to October 2016. We realised that in ppm_dwh database, in dwh_cmn_period, last monthly and quarterly period that exist is in October 2016. On test environment, they exist until 2020. Please, see the pictures attached.

    We also realized, there is 2 minutes difference between database and application server on production, while they are identical on test environment. Our techical guys are working on it and will come back to you with a result.