Clarity

Expand all | Collapse all

MSP Connector - Authentication issue

Jump to Best Answer
  • 1.  MSP Connector - Authentication issue

    Posted 10-28-2016 07:12 AM

    Hello,

     

    when we try 'Open in Scheduler', sched link is downloaded and when we click on it, authentication is required. System adds "clarity\" in username field, but usernames don't have any prefix in PPM tool, so project cannot be opened in MSP.

    Any advices how to remove this prefix from username fields?

     

    Thank you



  • 2.  Re: MSP Connector - Authentication issue

    Broadcom Employee
    Posted 11-07-2016 11:14 AM

    The prefix of "clarity\" should typically not impact successfully logging in.

     

    Are you able to login successfully if you remove the clarity prefix?

    If not, do you get any error when trying to login whether in the MSP Interface or app-ca.logs?

    If no error are you using the new driver or legacy driver? If the new driver do you see anything in the bottom right hand corner of MSP on where it is ending at? Example: Connecting to PPM, etc?

    Are you using any kind of proxy? If so, proxy information would also be required to login.



  • 3.  Re: MSP Connector - Authentication issue

    Posted 11-17-2016 04:45 AM

    Hello Kristin,

    thank you for the answer. Please, find the answers below.

     

    That exactly was the question – how to remove clarity prefix? We are NOT able to edit prefix in authentication screen. We are able to log in when we open project directly from MS Project, but when we use 'Open in Scheduler', described error appears. (Please find print screen attached.)

    We don't get any error, it just blinks, and Password needs to be entered again.

    We are using new driver, and when we open it directly from MS Project, in right bottom we see "Connecting to PPM", but every time, if we do it this way, we need to enter host, username and password.

    No, we are not using proxy.

     

    Thank you,

    Mateja



  • 4.  Re: MSP Connector - Authentication issue
    Best Answer

    Posted 12-19-2016 10:01 AM

    Scheduler Entry URL was missing.

     

    We did next steps:

     

    "Go to Clarity System Administration (CSA/NSA) and open the server, then go to Application tab. You will find Scheduler Entry URL.

     

    Ensure that in this attribute the URL that people type to get into PPM is there, e.g., if you access via http://ppm.mycompany.com, this is what should appear. Also, make sure that http or https is included in the URL and that /niku/nu is not there.

     

    After making any changes, please restart PPM services and try again."

     

    After that, there was no longer issues in using "Open in Scheduler" option.