Clarity

Expand all | Collapse all

How can I change the 'Key Task' default value for new tasks?

Jump to Best Answer
  • 1.  How can I change the 'Key Task' default value for new tasks?

    Posted 07-21-2016 03:27 PM

    My system is currently defaulting to blank in the Key Task field when new tasks are created.  The system documentation indicates that this should be checked off as a default.  I am not sure if we changed this default or if it changed when we upgrade to 14.2 but I would like to change it back and I cannot find where to do this.

     

    Can someone please help?  Thanks

     

    dennis



  • 2.  Re: How can I change the 'Key Task' default value for new tasks?

    Posted 07-21-2016 05:08 PM

    Hi Dennis,

     

    You can change what this attribute defaults to on the Task object.

     

    Go to the Administration Menu > Objects > Task > Attributes tab. Once here, look for the 'Key Task' attribute, click on it to open up the attribute properties and for the Default Value, check the box. Then click on Save and Return.

     

    New tasks that you create from now on will have this Key Task checkbox checked.

     

    I hope this helps!

     

    Regards,

    Maria Whiteside



  • 3.  Re: How can I change the 'Key Task' default value for new tasks?

    Posted 07-22-2016 08:16 AM

    Maria,

     

    Thanks for the advice but I had already done that in my QA system and the next time I tried to add a new task, the Key Task field was still defaulting to blank.  Am I missing a step to update the view with the new attribute values??

     

     

    dennis



  • 4.  Re: How can I change the 'Key Task' default value for new tasks?
    Best Answer

    Posted 07-22-2016 08:35 AM

    Setting the default at the attribute level is like setting the 'master default' value.  This master default value can be overridden in you views.  So, back to the Task Object, click on Views tab, and start look at the field properties for Key Task on your "create" view.  You may find that the default is unchecked, here.

     

    Check the default box, save and return, then Publish the view.

     

     

    Occasionally, rarely, in our multiple app server environment, we've had a problem with publishing not cascading changes to all servers - so, the published change would appear for one user, but not for another user, depending on the server that were routed to by the load balancer.  In this case, clearing caches on the affected server should force the affected app server to get the latest content.

     

    Also, in your browser (we use IE), make sure your page refresh settings are set to 'every visit to the page.'  Otherwise, the user's machine may be locally caching an old view and not getting the latest changes that you've published.

     

    Dale



  • 5.  Re: How can I change the 'Key Task' default value for new tasks?

    Posted 07-22-2016 09:14 AM
      |   view attached

    We have a winner!  Thanks Dale.  This is what I was missing.  I finally found this when I clicked on the appropriate  ‘Fields’ link on the ‘General task’ view

     

     

    dennis



  • 6.  Re: How can I change the 'Key Task' default value for new tasks?

    Posted 07-22-2016 09:22 AM

    Super!  Glad to help.