Clarity

Expand all | Collapse all

Does anyone know how to set the ETC to zero?

  • 1.  Does anyone know how to set the ETC to zero?

    Posted 10-27-2015 11:02 AM
      |   view attached

    We are using CA PPM 14.2 with Legacy connector. Currently we are not using the functionality of timesheet or tracking the hours for each resource in PPM.

    So, we set the default allocation % to zero, however, the value for ETC is still added whenever I replace a role to a resource.

    Because the ETC adding hours to Work, and that affect my whole schedule. It pushed the duration to hundreds days.

    Does anyone know how to set the ETC to zero for the resource after you assign the tasks?



  • 2.  Re: Does anyone know how to set the ETC to zero?

    Posted 10-27-2015 11:48 AM

    https://communities.ca.com/servlet/JiveServlet/download/241836073-123772/Capture.JPG

     

    The hard way is after you have it you go to the Tasks tab  and open the Assignments

    Click the properties icon and edit the ETC



  • 3.  Re: Does anyone know how to set the ETC to zero?

    Posted 10-27-2015 11:56 AM
      |   view attached

    Thank you very much! I am able to reset the ETC to zero now. However, do you know how to avoid that happen? I mean if the ETC is non-zero value, it affects my schedule. Even though now I am able to reset it to zero, but my schedule can never be the same anymore. (All the durations, dates are changed already)

    As you can see in the attachment, the ETC already added those hours to Work.



  • 4.  Re: Does anyone know how to set the ETC to zero?

    Posted 10-27-2015 12:09 PM

    The easy way:

     

    In MSP

    - Add column to Gantt view "Remaining Work"

    - Click into cell that you want to change

    - Set value to zero

    - After setting all Tasks' Remaining Work values to zero, save changes back to CA PPM

     

    The advantage of using MSP is that one can set ETC (Remaining Work) to zero at task level, cascading change to all assigned resources/roles.

     

    Do not set "% Complete" to 100% in MSP.  Yes, ETC (Remaining Work) will go to zero, but MSP assumes that all assigned work has been worked, converting it to Actual Work.



  • 5.  Re: Does anyone know how to set the ETC to zero?

    Posted 10-27-2015 01:16 PM
      |   view attached

    https://communities.ca.com/servlet/JiveServlet/download/241836109-123773/Capture.JPG

     

     

    What happens is that in Clarity when a resource is assigned to a task the effort (ETC) is set at full availability rate for each day of the duration and there is nothing the user can do about it.

    If OWB is used for creating the assignments that does not happen and the ETC for new assignments is zero.If you are using MS Project then OWB is not an option.

    For details see the attachment.

    Attachment(s)

    pdf
    ETC_in_Clarity_n_OWB.pdf   1.46MB 1 version


  • 6.  Re: Does anyone know how to set the ETC to zero?

    Posted 10-28-2015 10:05 AM

    Thank you for your reply. We use the template to create projects. And I just checked the Remaining Work column in the template, it's already set to 0hr, and % Complete is also set to 0.

    Weird thing is some resources when I assigned the role, the ETC go crazy, but some keep as 0. And there's no setting difference between those resources.

    Capture.JPG



  • 7.  Re: Does anyone know how to set the ETC to zero?

    Posted 10-28-2015 12:59 PM
      |   view attached

    I can’t replicate your issue, on 14.2.  But I have seen this type of thing in the past (ETC blowing Finish Date out to 2039), typically when allocating new team members to in-flight project where there exists a ‘fast plan’ task with ID = ~rmw and actual hours booked to task.  Today, can’t replicate this, no matter what I try (perhaps I’m still missing something, too).

     

    One thing you might check under Admin\Project Management\Settings is the Requisition Booking field.  Ours is set to “Use Allocation Percentage.”

     

    Wish I could say when this field came into being.  I’ve changed the value to “Use Available Work Units” with no effect – perhaps it needs to have the app restarted to take effect.  IFF some of your resources have no available work units, and some do, THEN this setting might have something to do with your scenario.

     

    I can’t test this further, as this is not what I’m getting paid for.  I do have interest in the root cause/solution as this might be a future issue for us, as we are finally starting down WBS/Scheduling path.

     

     



  • 8.  Re: Does anyone know how to set the ETC to zero?

    Posted 10-28-2015 01:36 PM

    Yes, our setting is set to "Use Allocation Percentage"

    It is very odd, I created a test project yesterday and assigned resources to that project, all ETC were 0 (which is good). However, today I used the same project and assigned more resources to the team, ETC went crazy...

    Can't figure it out the root cause, I really hope it's not a new bug in the application.



  • 9.  Re: Does anyone know how to set the ETC to zero?

    Posted 10-27-2015 12:55 PM

    You might explore the use of the 'default value' for the ETC attribute on the Assignment object in Studio.  Not sure if you provide a default value if it overides the behavor that generates an initial ETC value once the resources is assigned to the task.



  • 10.  Re: Does anyone know how to set the ETC to zero?

    Posted 10-27-2015 04:17 PM

    Can you just change the default Task Type to "Fixed Duration" (set "Fixed Duration" to True)? That way, the "work" figure - Actuals or ETC - won't make any changes to dates?



  • 11.  Re: Does anyone know how to set the ETC to zero?

    Posted 10-27-2015 04:25 PM

    We are using template to create the project, and in the template, all the tasks are set to "Fixed Duration" and Work is set to "0hr". But once we assign the resource from the Team tab, the ETC issue happens. If we assign resource to individual task, we don't have this issue.



  • 12.  Re: Does anyone know how to set the ETC to zero?

    Posted 01-25-2016 09:11 AM

    Reply to CA:  When the last reply is "still have problem," why is question status changed to "Assumed Answered?"

     

    If question status is changed, it should be to something like "Customer gave up in frustration."



  • 13.  Re: Does anyone know how to set the ETC to zero?

    Posted 02-15-2016 12:16 PM

    Hi Dale,

     

    PPM added the ETC value to the project and that affect the duration and the schedule. We have been working with CA Support and this issue has been logged as a product defect. I guess that's why the status changed to "assumed answered"



  • 14.  Re: Does anyone know how to set the ETC to zero?

    Posted 02-15-2016 01:14 PM

    Thank you for the update.

     

    Wish then that CA would use a status of “Bug Identified” with a link to its case number and status.  “Answered” and “Assumed Answered” imply resolution, which in this case, is not true.

     

    For now, I can only hope that we don’t run into this bug ourselves.

     

    Take care – hope this gets fixed for you soon.