Clarity

Expand all | Collapse all

Jaspersoft issue alert: Jaspersoft reports do not open when external SSL is used on 14.2.0 - resolved in 14.2.0.1, now available for OP

  • 1.  Jaspersoft issue alert: Jaspersoft reports do not open when external SSL is used on 14.2.0 - resolved in 14.2.0.1, now available for OP

    Posted 05-22-2015 10:01 AM

    Hello fellow communities members,

     


    There is a known issue with Jaspersoft and SSL that is now been resolved in 14.2.0.1 which is now available on Support site for On Premise customers. Please ensure you install it if you believe you may hit the issue. The patch also includes few important bug fixes for 14.2, so I would recommend you to install it even if you don't have it.

     

    Here are the details on the issue, please take a look:

     

    CLRT-77687 : Jaspersoft request processor does not correctly handle requests when Clarity is configured for external SSL

    Steps to Reproduce: 
    1. Set SSL mode in the application server to "external"
    2. Set HTTPS OFF for the application server
    3. Specify an entryUrl that points to the external SSL-enabled server
    4. Specify 8080 for the HTTP port (or any port number above 80 - the code explicitly skips port 80)
    5. Log in to Clarity with a user that has all Advanced Reporting rights
    5. Attempt to run any report

     

     

    Expected Result: The report runs normally. All requests use the standard entryUrl value exactly as it is specified
    Actual Result: The report times out or just fails. Browser request tracing will reveal that the HTTP port has been inserted into the Jaspersoft request URL along the way

     

    Hope this helps!

     

    Kind Regards

     

    Nika Hadzhikidi
    CA Technologies
    Principal Support Engineer



  • 2.  Re: Jaspersoft issue alert: Jaspersoft reports do not open when external SSL is used on 14.2.0 - resolved in 14.2.0.1, now available for OP

    Posted 05-22-2015 11:28 AM

    Thanks for alerting the community Nika!

    NIKA HADZHIKIDI wrote:

     

    Hello fellow communities members,

     


    There is a known issue with Jaspersoft and SSL that is now been resolved in 14.2.0.1 which is now available on Support site for On Premise customers. Please ensure you install it if you believe you may hit the issue. The patch also includes few important bug fixes for 14.2, so I would recommend you to install it even if you don't have it.

     

    Here are the details on the issue, please take a look:

     

    CLRT-77687 : Jaspersoft request processor does not correctly handle requests when Clarity is configured for external SSL

    Steps to Reproduce: 
    1. Set SSL mode in the application server to "external"
    2. Set HTTPS OFF for the application server
    3. Specify an entryUrl that points to the external SSL-enabled server
    4. Specify 8080 for the HTTP port (or any port number above 80 - the code explicitly skips port 80)
    5. Log in to Clarity with a user that has all Advanced Reporting rights
    5. Attempt to run any report

     

     

    Expected Result: The report runs normally. All requests use the standard entryUrl value exactly as it is specified
    Actual Result: The report times out or just fails. Browser request tracing will reveal that the HTTP port has been inserted into the Jaspersoft request URL along the way

     

    Hope this helps!

     

    Kind Regards

     

    Nika Hadzhikidi
    CA Technologies
    Principal Support Engineer



  • 3.  Re: Jaspersoft issue alert: Jaspersoft reports do not open when external SSL is used on 14.2.0 - resolved in 14.2.0.1, now available for OP

    Posted 05-25-2015 01:24 AM

    Thanks for sharing this info, Nika

     

    Regards

    NJ



  • 4.  Re: Jaspersoft issue alert: Jaspersoft reports do not open when external SSL is used on 14.2.0 - resolved in 14.2.0.1, now available for OP

    Posted 05-25-2015 03:47 AM

    Issues Fixed in 14.2.0.1   

    CLRT-77687  Jaspersoft request processor does not correctly handle requests when Clarity is configured for external SSL   

    CLRT-77517  XOG fails on customObjectInstance associated to Department OBS containing single quote   

    CLRT-75934  Team Staff OBS Unit is not cleared from the database when OBS Unit is deleted from the Admin Tool   

    CLRT-77181  Large String Attributes not editable in Internet Explorer 11   

    CLRT-76643  TABLE_NAME is corrupted in PRJ_OBS_ASSOCIATIONS when creating a Service.   

    CLRT-77061  Billing currency rate for an Idea gets changed to the default value automatically once Save button is clicked in some other subpage   

    CLRT-77179  Process triggering when starting condition is not met   

    CLRT-77468  If the size of an attribute is changed, the portfolio sync job fails   

    CLRT-77392  Metrics missing from the Portfolio Provider data provider   

    CLRT-77539  Idea Financial Plans in Portfolio Spread when Save is done on the idea   

    CLRT-77500  Gel Script fails in 14.2 when HTML img tag is present   



  • 5.  Re: Jaspersoft issue alert: Jaspersoft reports do not open when external SSL is used on 14.2.0 - resolved in 14.2.0.1, now available for OP

    Posted 05-25-2015 04:53 AM

    Thanks for sharing this, urmas

     

    Regards

    NJ