Clarity

Expand all | Collapse all

HTTP Error 404.0 - Not Found

Jump to Best Answer
  • 1.  HTTP Error 404.0 - Not Found

    Posted 09-18-2015 02:28 PM

    Hi everyone

    I have managed to install the database and configured clarity, but when I try to enter the Management Console clarity, showed me the following error:

    error_clarity.png

    regards,

    Marco Velazquez



  • 2.  Re: HTTP Error 404.0 - Not Found

    Posted 09-18-2015 04:06 PM

    That used to be the error you get when the app server in not up.

    Are you using IIS as webserver?

    Have you started beacon and CSA service.



  • 3.  Re: HTTP Error 404.0 - Not Found

    Posted 09-18-2015 04:33 PM

    Hi urmas,

     

    I installed tomcat for my clarity, my beacon service starts without problems.

    I tried to enter the management console with the following link:

    http://clarity133/niku/app

    and my installation is now complete and showed me no error

    clarity_susessfully.png

     

    any idea about the problem?

    services clarity.png

     

    regards,

    Marco Velazquez.



  • 4.  Re: HTTP Error 404.0 - Not Found

    Posted 09-18-2015 04:53 PM

    Hi Marco,

     

    Are you using IIS to manage Clarity?

    Please could you try accessing the application with the link: http://clarity133/niku/nu

    If you still have a 404 message, please ensure IIS is properly configured,  Clarity OS user has full rights over Clarity directory, and trace the request with a tool such as Fiddler or Dev tools to see what is happening.

     

    Please let me know how it goes.

     

    Kind Regards

     

    Nika Hadzhikidi

    CA Technologies

    Principal Support Engineer



  • 5.  Re: HTTP Error 404.0 - Not Found

    Posted 09-18-2015 05:04 PM

    Hi Nika Hadzhikidi,

     

    I tried to enter the link as you recommended:

    http://clarity133/niku/nu

    error_IIS.png

    but the error persists. I used the option to tomcat for my installation of clarity

    Please can you support me with the proper steps to configure IIS, if that is the problem. I will be very grateful.

     

    regards,

    Marco Velazquez.



  • 6.  Re: HTTP Error 404.0 - Not Found

    Posted 09-19-2015 02:17 AM

    When you say

    when I try to enter the Management Console clarity, showed me the following error:

    That is not entirely true, because you have posted a screenshot from the management console above where it says the installation is complete.

    That also indicates that your Tomcat setup is OK.

    What you write suggests that you DO have also IIS.

    If that is the case then it is likely that IIS is using the default port 80 and therefore you cannot access Clarity. You can access the Management console because that is at port 8090.

    Pick a free port for the app server like 81 and set in in the Management console on the pages where you have the properties for the servcies.

    How does you All Service page display in the Management console?



  • 7.  Re: HTTP Error 404.0 - Not Found

    Posted 09-21-2015 09:33 AM

    I would agree and encourage with almost everything here - the only adjustment I might suggest is that:

     

    a) If you didn't even know IIS was enabled on the server

    b) You have no apparent need of IIS on the server

     

    Then rather than reconfigure Clarity's port so they can both live in harmony, just shut off IIS - this will leave your system more secure (because the above would likely imply you have default credentials and setup for IIS which can be a vulnerable position), as well as free up some resources for the Clarity services that are being wasted.

     

    If administrating the server isn't your (the OP's) role though, then before making a decision either way, check with the person who is the administrator and see if IIS is needed and desired on this machine.

     

    Usually with our customer base, the experience I have is that IIS was not wanted or even 'known' when conflicts arise with it, but I acknowledge that won't be the case every time.



  • 8.  Re: HTTP Error 404.0 - Not Found
    Best Answer

    Posted 09-21-2015 10:35 AM

    I don't disagree with that.

    Not being a technical person it is just easier for me personally to change the CA PPM port than to figure out if IIS on the system and how to turn it off. ;-)



  • 9.  Re: HTTP Error 404.0 - Not Found

    Posted 09-21-2015 11:19 AM

    Hello everyone,

     

    I changed the port for 81 tomcat in clarity, and everything worked properly. Thank you very much for your help.

     

    Clarity.png

    regards,

    Marco Velazquez.



  • 10.  Re: HTTP Error 404.0 - Not Found

    Posted 04-12-2018 08:08 AM

    Hello,

    I am also getting the same error and looks like issue with IIS set up. Do we have any document to configure IIS for Ca PPM. Please help @urmas also



  • 11.  Re: HTTP Error 404.0 - Not Found

    Posted 04-12-2018 10:04 AM

    My problem was solved using first another port and the finally not having IIS up at all.

    Why do you want to use IIS?

    Is that supported?



  • 12.  Re: HTTP Error 404.0 - Not Found

    Posted 04-12-2018 11:09 AM

    We have done the SSO set up with CA Siteminder-IIS web agent. but after logging in SSO, request is not routing to Clarity application. Siteminder setting looks okay so just need to check on any setting on IIS side that causing the issue.