Symantec IGA

Expand all | Collapse all

OS400 idm issue: locked is not a property of OS400.Account

Jump to Best Answer
  • 1.  OS400 idm issue: locked is not a property of OS400.Account

    Posted 06-22-2017 04:46 PM

    Hi experts,

     

    I created an OS400 Endpoint. Explore and correlation worked fine, as I have several new global users with OS400 accounts.

     

    But when I try to unlock any of them, I receive 'locked' is not a property of OS400.Account

     

    Do you know what can be happening? This is the OOTB installed connector, only created the Endpoint (no ssl for now).

     

    Thanks in advance!



  • 2.  Re: OS400 idm issue: locked is not a property of OS400.Account
    Best Answer

    Posted 06-23-2017 10:22 AM

    Hello Julian, 

     

    The page for managing accounts in the Identity Manager web UI is generic, to accommodate all of the different connectors we have. However, not all connectors have the same features and functionality so not every button on that page works for every connector. 

     

    The Lock/Unlock feature is present in a few Identity Manager connectors but not all of them. OS400 is one of our connectors were you cannot manage lock/unlock through Identity Manager. So, the error you're seeing is expected behavior. 

     

    The management of locking and unlocking OS400 accounts must be done naively on your endpoint. 

     

    If you'd like to see Lock/Unlock added as a property to the OS400 connector, please open up an enhancement request. 

     

    Thank you, 

    Jennifer Johnston