Symantec IGA

What to do when you're unable to assign a Provisioning Role

  • 1.  What to do when you're unable to assign a Provisioning Role

    Posted 07-30-2015 11:21 AM

    When assigning a provisioning role to a user you receive the following or similar error:

     

    This method requires the presence of an attribute which was not provided. The attribute is named carLicense.

     

    The reason why you experience this issue is because %ENABLED_STATE% was not mapped during the creation of your directories and environment. To resolve this issue please do the following:

     

    Confirm that you mapped %ENABLED_STATE% in both prov and corp directories.

     

    Example:

         Corporate Directory(Home Directories Corp Store User):

                   Display Name                         Physical Name                    Well-Known Name

                   Enabled State                         carLicense                           %ENABLED_STATE%

       

         Provisioning Directory (Home Directories Prov Store Global User):

                 Display Name                         Physical Name                    Well-Known Name

                  Disabled State                         eTIMEnabledState               %ENABLED_STATE%

     

    Confirm that you Enabled_state% to Enabled_state% within environment (Advanced Settings › Provisioning > Attribute Mappings)

     

    Example:

            IM Environment (Home Environments im Advanced Settings Provisioning):

                Under Attribute Mappings set the following:

                        User Attribute                   Provisioning Attribute

                        %ENABLED_STATE%     %ENABLED_STATE%


    Save your environment, restart your environment and you should be able to assign provisioning roles now.