DX NetOps

Expand all | Collapse all

Not able to Install spectrum 10.14 on linux server

Jump to Best Answer
  • 1.  Not able to Install spectrum 10.14 on linux server

    Posted 11-19-2019 07:57 AM
    Hi Team,

    We are trying to install spectrum 10.4 in RHEL 7.5, while running the installer,  its getting aborted and throwing the below message.We use the option ./installer.bin -i console.

    Could you let us know how take it further
    --------------------------------------------------------
    The installer cannot run in this UI mode.To specify the interface mode , use the -i command-line option,followed by the UI mode identifier.The valid UI modes identifiers are GUI,Console and silent,
    --------------------------------------------------------

    Thanks
    KR


  • 2.  RE: Not able to Install spectrum 10.14 on linux server

    Posted 11-19-2019 07:58 AM
    There was a typo.

    we are trying to install 10.4 not 10.14


  • 3.  RE: Not able to Install spectrum 10.14 on linux server
    Best Answer

    Posted 11-19-2019 10:22 AM
    Kamal,

    It is likely that you are missing some of the required packages:

    https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/spectrum/10-4/installing-and-upgrading/fresh-install/system-requirements-for-installing-ca-spectrum/spectroserver-and-oneclick-requirements/system-requirements-for-linux.html

    As there is some slowdown on the doc site at the moment, here is a list of the packages as an excerpt from the docs:

     
    Note
    : For purposes of identification, 32-bit RPMs for Red Hat Enterprise Linux contain "i386" or "i686". The 64-bit RPMs contain "x86_64".
    Install the following 64-bit RPMs and its dependencies, for the respective RHEL version:
    • libnuma (required for MySQL v5.7)
    • elfutils-libelf
    • libaio (required for MySQL v5.5, the MySQL version for the database)
    • ncurses
    • ncurses-libs (RHEL 6.x or 7.x)
    • xterm
    • ksh
    • xorg-x11-fonts-misc 
    • PackageKit-gtk-module or PackageKit-gtk3-module (for RHEL 7.x)
    • libcanberra-gtk2 
    • gtk2-engines (not required for RHEL 6.4 or later versions)
    Install the following 32-bit and 64-bit RPMs and its dependencies, for the respective RHEL version:
    • openmotif (RHEL 6.x) or motif (RHEL 7.x)
    • glibc
    • nss-softokn-freebl
    • libICE
    • libSM
    • libX11
    • libXext
    • libXft
    • libXmu
    • libXp
    • libXrender
    • libXt
    • fontconfig
    • freetype
    • libjpeg -  libjpeg-turbo ( RHEL 6.x,7.x)
    • libpng
    • libuuid
    • libxcb
    • libXau
    • expat
    • zlib
    • libstdc++
    • libgcc
    • libXi
    • libXtst
    Regards,
    Troy