DX NetOps

Expand all | Collapse all

OData Query Builder is not accepting any user credentials.

  • 1.  OData Query Builder is not accepting any user credentials.

    Posted 10-09-2018 03:25 AM

    Hi Community

     

    Our client want to integrate CAPM with other tool for centralized dashboards and asked for Odata access for the same. I am trying to launch the query builder using the URL: http://DA_host:8581/odataquery but it is not taking any of the user  (not even default admin) credentials. We do not have LDAP configured on CAPC. Kindly suggest.

     

    Thanks in advance

    Soumyadipta Ganguly



  • 2.  Re: OData Query Builder is not accepting any user credentials.

    Broadcom Employee
    Posted 10-09-2018 10:05 AM

    Hi Soumyadipta,

     

    What CA Performance Manager release is involved?

     

    It sounds like you do get the OpenAPI Querybuilder log in page, where you enter the user name and password correct?

     

    What message is observed when trying to log in using a user that is confirmed to work for regular UI access?

     

    Thanks,

    Mike



  • 3.  Re: OData Query Builder is not accepting any user credentials.

    Broadcom Employee
    Posted 10-09-2018 11:50 AM

    Soumyadipta,

     

    In addition to what Mike said, you mentioned you do not use LDAP but do you use HTTPS in CAPC?  Some things to check in the CAPC command line:

     

     

    1. cat /opt/CA/PerformanceCenter/PC/webapps/pc/WEB-INF/cfg/CADataAggregator.xml

     

    The top port should be 8581

     

    2. Run:  /opt/CA/PerformanceCenter/SsoConfig

     

    Option 1

    Option 3

     

    Is the Web Site Host listed correctly?  If it is not, do you have multiple interfaces listed within ifconfig?

     

    Regards,

    Troy



  • 4.  Re: OData Query Builder is not accepting any user credentials.

    Posted 10-10-2018 05:46 AM

    Hi Mike

     

    We have Performance Management version 3.5 on which we are trying the same. After we are putting the default admin credentials, the page is getting refreshed and not logging in. I had tried with sudo user for installation, it is saying the user credentials are wrong.

     

     

    Thanks

    Soumyadipta



  • 5.  Re: OData Query Builder is not accepting any user credentials.

    Posted 10-10-2018 05:54 AM

    Hi Troy

     

    Thanks for your inputs. Following are my answers to your questions.

    1. I did not get any directory as  /opt/CA/PerformanceCenter/PC/webapps/pc/WEB-INF/cfg/. Is it supposed to be present there?

    2. Following is the result of SsoConfig as you suggested.

    #####################################

    SSO Configuration/CA Performance Center:
    1. LDAP Authentication
    2. SAML2 Authentication
    3. Performance Center
    4. Single Sign-On
    5. Test LDAP
    6. Export SAML2 Service Provider Metadata
    7. Enable FIPS
    Choose an option > 1

    SSO Configuration/CA Performance Center/LDAP Authentication:
    Connection User:
    Connection Password:
    Search Domain:
    Search String:
    Search Scope:
    User Bind: Disabled
    Encryption:
    Account User:
    Account User Default Clone:
    Group:
    Krb5ConfigFile:
    Status: Enabled
    Timeout: 10000

    1. Remote Value
    2. Local Override
    Choose an option > b

    SSO Configuration/CA Performance Center:
    1. LDAP Authentication
    2. SAML2 Authentication
    3. Performance Center
    4. Single Sign-On
    5. Test LDAP
    6. Export SAML2 Service Provider Metadata
    7. Enable FIPS
    Choose an option > 3

    SSO Configuration/CA Performance Center/Performance Center:
    Web Service Scheme: http
    Web Service Host: 10.43.6.11
    Web Service Port: 8481
    Web Service Inventory (Version 1): /dm/inventory
    Web Service Data Source Admin: /dm/ds
    Web Site Scheme: http
    Web Site Host: 10.43.6.11
    Web Site Port: 8181
    Web Site Path: /pc/desktop/page
    SMTP Enabled: Enabled
    SMTP Server Address: smtp.hvwan.net
    SMTP Ports: 25
    SMTP SSL: Disabled
    Email Reply Address: capm@husqvarnagroup.com
    Email Format: HTML
    SMTP Username:
    SMTP Password:
    Web Service Inventory (Version 2): /dm/inventory2
    SMTP Authentication: Disabled

    #####################################

     

    Thanks

    Soumyadipta



  • 6.  Re: OData Query Builder is not accepting any user credentials.

    Posted 10-10-2018 06:00 AM

    Hi Troy

     

    Sorry my bad. I missed the path last time. I can see the file /opt/CA/PerformanceCenter/PC/webapps/pc/WEB-INF/cfg/CADataAggregator.xml now and as you suggested, the top port is 8581 only.

     

    <Configuration>
    <SingleSignOnEnabled>True</SingleSignOnEnabled>
    <SingleSignOnProductCode>da</SingleSignOnProductCode>
    <RemoteWebSite>True</RemoteWebSite>
    <SignInPageProductDefaultUrl>
    <Scheme>http</Scheme>
    <Port>8581</Port>
    <PathAndQuery>/odataquery/index.html</PathAndQuery>
    </SignInPageProductDefaultUrl>
    <SingleSignOnWebServiceUrl>
    <Scheme>http</Scheme>
    <Port>8181</Port>
    <PathAndQuery>/pc/center/webservice/sso</PathAndQuery>
    </SingleSignOnWebServiceUrl>

     

     

    Thanks

    Soumyadipta



  • 7.  Re: OData Query Builder is not accepting any user credentials.

    Posted 10-23-2018 04:38 AM

    Hi all

     

    Kindly suggest to get the fixed. We are still facing the same issue. I had uploaded all the details requested.

     

    THanks

    Soumyadipta



  • 8.  Re: OData Query Builder is not accepting any user credentials.

    Broadcom Employee
    Posted 10-23-2018 07:29 AM

    Soumyadipta,

     

    My apologies, I am unsure why I called out the PC version of this file.  Take a look at the sso version below and compare it to the PC version you already linked.  If it is the same I would advise you to open a full support case on this problem.

     

    /opt/CA/PerformanceCenter/sso/webapps/sso/WEB-INF/cfg/CADataAggregator.xml

     

    Regards,

    Troy