AutoSys Workload Automation

Expand all | Collapse all

Micro Focus Plugin Agent with TCPSSL

Jump to Best Answer
  • 1.  Micro Focus Plugin Agent with TCPSSL

    Posted 12-05-2019 02:21 PM
    ​Hi,

    Has anyone experienced upgrading an MF agent to use SSL along with TCP? We have a client that has a Microfocus job that works fine on their on-prem server using the following connection string:

    tcp:servername:30162

    When they run the same job on their new cloud server, due to tighter protocols, they use the following string:

    tcpssl:servername:30162

    The on-prem agent is R11.3.4, build 45 and the cloud agent is R11.4.01, build 56.

    The job runs fine under the older version but is not successful on the newer agent. The job gets submitted and the user can tell the job completes on the agent/server side, but the status of the job never changes from "READY". We can't see any difference on the receiver/transmitter between the two, other than the COMPLETE communication never gets sent back to the Master.

    Just wondering if it could be the difference in the builds.


  • 2.  RE: Micro Focus Plugin Agent with TCPSSL

    Posted 12-06-2019 12:54 AM
    Hi,

    Looking at the problem , looks like the agent is unable to send the "proper state/status" messages to the Server back . As a result , the server is not getting updated with the right status and showing as "READY". 
    I would suggest that you open a ticket to analyze the agent logs as to know why it is not able to send the messages back to server.


    Hope it helps!
    Ravi Kiran


  • 3.  RE: Micro Focus Plugin Agent with TCPSSL
    Best Answer

    Posted 12-06-2019 06:03 PM
    ​Hi Kiran,

    After I posted my question, I re-reviewed the steps needed to install the MF plugin agent. We missed this step:

    Load the event_manager Exit Routine on Windows

    You configure a Micro Focus Enterprise Server environment variable to load the event_manager exit routine that passes Micro Focus event information to the agent.

    So, no "real" MF information was even being sent to the agent. Once we set that up and had the server rebooted, the job ran successfully.

    Thanks for the support,
    Denise