AutoSys Workload Automation

Expand all | Collapse all

Appplication Services plugin doesnt install

Jump to Best Answer
  • 1.  Appplication Services plugin doesnt install

    Posted 04-16-2018 11:05 PM

    Has anyone had success isntalling the appservices plugin on the latest agent (11.4)?

     

    I keep running into this issue:

     

    [root@rhel7-ae-1 WA_AGENT]# ./PluginInstaller /tmp/appservices.pak .
    Do you want to set up the alias? (Y/N): N
    /opt/CA/WorkloadAutomationAE/SystemAgent/WA_AGENT/jars/dataservices.jar exists. Override(Y/N/A)? A
    Extracting /opt/CA/WorkloadAutomationAE/SystemAgent/WA_AGENT/jars/dataservices.jar ...
    Extracting /opt/CA/WorkloadAutomationAE/SystemAgent/WA_AGENT/jars/appservices.jar ...
    Extracting /opt/CA/WorkloadAutomationAE/SystemAgent/WA_AGENT/jars/commonsvc_transport.jar ...
    Extracting /opt/CA/WorkloadAutomationAE/SystemAgent/WA_AGENT/jars/commonsvc_log.jar ...
    Installer failed: /opt/CA/WorkloadAutomationAE/SystemAgent/WA_AGENT/jars/ext/axis-schema.jar is not a file in the agent directory. It cannot be backed up.



  • 2.  Re: Appplication Services plugin doesnt install
    Best Answer

    Posted 04-16-2018 11:18 PM

    Hi Deekshit,

    I have seen this problem before, could you try the complete path for the agent install directory instead of "."?

      

        #./PluginInstaller /tmp/appservices.pak /opt/CA/WorkloadAutomationAE/SystemAgent/WA_AGENT/

     

    Thank You!

    Kishore Kumar Udathaneni



  • 3.  Re: Appplication Services plugin doesnt install

    Posted 04-16-2018 11:25 PM

    That worked…is this a bug/known issue being worked on?

     

    Thank you!



  • 4.  Re: Appplication Services plugin doesnt install

    Posted 04-18-2018 09:04 AM

    Hi Deekshit,

    I see it updated in the known issues for Agent 11.4. 

    https://docops.ca.com/ca-workload-automation-system-agent/11-4/en/release-notes#ReleaseNotes-KnownIssues

    Will be resolved in the upcoming release(s).

    Thank You!

     

    Regards,

    Kishore Kumar Udathaneni



  • 5.  Re: Appplication Services plugin doesnt install

    Posted 04-18-2018 09:08 AM

    Hi,

    You can try this if you don't want to type out the whole path.

    #./PluginInstaller /tmp/appservices.pak `pwd`

     

    Thanks,

    Nitin Pande

    CA Technologies