Workload Automation

Expand all | Collapse all

Uninstall Autosys R11.0 client question

Jump to Best Answer
  • 1.  Uninstall Autosys R11.0 client question

    Posted 06-22-2017 11:47 AM

    Are there any gotchas when uninstalling an Autosys R11.0 client and then install the R11.3.6 on a Linux server?  From what I've been told the r11 and r11.3.6 client binaries cannot live together on the same machine.  I plan to uninstall the old client using the original R11 SP5 source DVD.  Then perform a new install of the client using the 11.3.6 media.

     

    Thanks



  • 2.  Re: Uninstall Autosys R11.0 client question
    Best Answer

    Posted 06-22-2017 12:36 PM

    We have both versions side by side on many thousands of agents/clients. Maybe you were told otherwise for the application/scheduler server side?



  • 3.  Re: Uninstall Autosys R11.0 client question

    Posted 06-22-2017 12:39 PM

    11.0/11.3 are WAY different. They can live side by side. Similar to 4.5 etc

    But test it on a dev server

     

    Steve C.

     

     

    Nothing in this message is intended to constitute an electronic signature unless a specific statement to the contrary is included in this message.

     

    Confidentiality Note: This message is intended only for the person or entity to which it is addressed. It may contain confidential and/or privileged material. Any review, transmission, dissemination or other use, or taking of any action in reliance upon this message by persons or entities other than the intended recipient is prohibited and may be unlawful. If you received this message in error, please contact the sender and delete it from your computer.



  • 4.  Re: Uninstall Autosys R11.0 client question

    Posted 06-22-2017 12:42 PM

    Thanks Steve & Lisa - 2 confirms from real world cases make me feel more confident.  We're doing this in a non-prod server first.  Fingers crossed. thx!



  • 5.  Re: Uninstall Autosys R11.0 client question

    Posted 06-22-2017 12:40 PM

    CA technical contact told us specifically the clients couldn't be installed together but agents were fine.  So you are running 11.3.6 client utility on same server as older r11.0?

    Did you need to make any env or other changes after the 11.3.6 client install was performed?



  • 6.  Re: Uninstall Autosys R11.0 client question

    Posted 06-22-2017 12:44 PM

    Yes i wouldn’t trust a client.

    Agents yes

     

     

    Steve C.

     

     

    Nothing in this message is intended to constitute an electronic signature unless a specific statement to the contrary is included in this message.

     

    Confidentiality Note: This message is intended only for the person or entity to which it is addressed. It may contain confidential and/or privileged material. Any review, transmission, dissemination or other use, or taking of any action in reliance upon this message by persons or entities other than the intended recipient is prohibited and may be unlawful. If you received this message in error, please contact the sender and delete it from your computer.



  • 7.  Re: Uninstall Autosys R11.0 client question

    Posted 06-22-2017 12:45 PM

    Yes we have clients installed that can communicate with both r11 and r11.3 instances. We are migrating off r11 gradually so they keep their jobs up in r11 until migration day and then port to r11.3.

     

    I’m not saying we haven’t made changes, because we like the system agent to behave like the r11 agent as much as possible for the job owners, but I don’t think they were huge changes. It is possible to have them both on the same server for us. Maybe your environment is different (database, encryption, etc.)



  • 8.  Re: Uninstall Autosys R11.0 client question

    Posted 06-22-2017 01:14 PM


  • 9.  Re: Uninstall Autosys R11.0 client question

    Posted 06-22-2017 04:19 PM

    The 11.0 and 11.3.6 clients can co-exist. There are a few caveats:

    The common component (CAPKI, CSAM) versions coincide at 11.0 SP5 INC3 and 11.3.6 base. CSAM 2.2.8 and CAPKI 4.3.6. Co-existing clients should be run using these releases.

    On Windows it will be necessary to poke the registry before and after the 11.3.6 client install (can be scripted). Otherwise the 11.3.6 installer will detect the existing 11.0 client and abort.

     

    As was previously mentioned the agents are completely separate and can co-exist.

     

    Instance-wide encryption must be disabled in the 11.3.6 environment if the 11.3.6 scheduler is communicating to both agent versions.