Automic Workload Automation

Expand all | Collapse all

Frequent Errors / Warning Messages using Automic Web Interface

Jump to Best Answer
  • 1.  Frequent Errors / Warning Messages using Automic Web Interface

    Posted 28 days ago
    Hi All,

    I am getting frequent error messages when i am logged in to awi & have to login again & again to work on automic. 
    It is the same case on IE, Chrome & other web browser.

    Error like as below:



  • 2.  RE: Frequent Errors / Warning Messages using Automic Web Interface

    Posted 28 days ago
    Is this Automic 12.3?
    What version of JRE are you using?

    ------------------------------
    Enterprise Solutions Architect
    Broadcom
    ------------------------------



  • 3.  RE: Frequent Errors / Warning Messages using Automic Web Interface

    Posted 20 days ago

    Automic version is 12.0

    Below is the version details. Also the count of this issue increased to 5 now. 5 Users are facing the same issue quite frequently so they have to relogin again & again.

    We have raised the support case as well but didnt get the clear instructions on what to do. Executive just said its known issue in 12.0, try other versions in which this issue was fixed & awaiting for his reply to know if its version upgrade or patch or incremental etc.

     

    Web Interface​

    Version:​

    Automic Web Interface 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774​

    Installed Plug-ins:​

    Administration Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Agent Group Authorizations Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Agent Group Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Agent Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Calendar Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Client Object Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Connection R3 plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Dashboards Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Event Console Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Event DB Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Event-File Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Event-Time Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    File Transfer Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Generic Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    HSTA Sheet plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    JOBQ SAP RemoteTaskMaager Sheets Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Jobs BS2000 Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Jobs GCOS8 Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Jobs JMX Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Jobs OS390 Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Jobs OS400 Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Jobs SQL Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Login Object Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    NSK Sheet Plugin for JOBS objects 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Notification Sheet plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Object Common Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Oracle Application Sheet Plugin for JOBS objects 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Output Filter Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    PS Sheet Plugin for JOBS objects 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Period Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Process Automation Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    PromptSet Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Prompts Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Queue Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Rapid Automation Core Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Rapid Automation FTP Sheet Plugin 4.0.1-build.35 ​

    Rapid Automation Oracle Retail Agent Plugin 2.1.1-build.1266 ​

    RunTime Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    SAP Sheet Plugin for JOBS SAP_ABAP objects 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    SAP Sheet Plugin for JOBS SAP_JAVA objects 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    SAP Sheet Plugin for JOBS SAP_PI objects 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    SQL Connection Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Schedule Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Service Level Objective Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Sheet Plugin for JOBQ PS remote taskmanager objects 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Siebel Sheet Plugin for JOBS objects 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Store Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Sync Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Timezone Sheet Plugin for Timezone objects 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Unix Sheet Plugin for JOBS objects 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    User Management Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Usersettings Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    VARA Backend Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    VARA Exec Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    VARA Filelist Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    VARA Multi Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    VARA SQL Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    VARA SQLI Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    VARA Secured SQL Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    VARA Secured SQLI Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    VARA Static Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    VARA XML Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    VMS Sheet Plugin for JOBS objects 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Windows Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Workflow Tab-Sheets Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    XSL Sheet Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Youtube Widget Plugin 12.0.6.hf2-dev-feature-12.0.6-hf.2-82774 ​

    Automation Engine API Version​

    Automation Engine API 12.0.6+build.10533​

     




  • 4.  RE: Frequent Errors / Warning Messages using Automic Web Interface

    Posted 20 days ago
    JRE version should not really matter, unless one is concerned​ with the JCP/JWP. The AWI is pure HTML and does not depend on any client side java.

    As for the error message at hand: I'm afraid the response from support might be as good as it gets. We had many occurences where we were told, also, that issues are fixed in later versions.

    And while 12.0 technically still does have support (or so I think ...), Broadcom/Automic does not appear to be in the habit of backporting fixes into old versions.

    The good news is, while not this exact issue, we had similar issues in 12.0 and 12.1, and there are many fixes in those areas in 12.2 and 12.3. So once you upgrade to 12.3, there is a reasonable chance that your issue will in fact disappear.

    But yes, at present time, there appears to be no real alternative to tracking the latest and greatest releases even in production. Meaning if you want bugfixes, you'll have to upgrade whenever Automic releases a new version.

    Br,


  • 5.  RE: Frequent Errors / Warning Messages using Automic Web Interface

    Posted 20 days ago
    But we are not in position to upgrade the automic version to 12.3 as we are in mid way of project where client is already having Automic 12.0 & is migrating from Appworx to existing Automic.

    Having a version upgrade will be a complete NO at the moment. 
    There got to be some workarounds/fixes/patches to fix this issue.


  • 6.  RE: Frequent Errors / Warning Messages using Automic Web Interface

    Posted 19 days ago
    Edited by Carsten Schmitz 19 days ago
    ​I understand your situation and I am very curious to learn if you do get anywhere with that request at Automic/Broadcom, so please keep us updated on any news.

    But we have been fighting that same battle for the better part of two years, with no luck, and have resigned to having to update with each new release. Your mileage may vary.

    One option that may come up sooner or later is HCL. It's a consultancy company chosen by Broadcom to provide consultancy services arround Automic software. I'm not sure if they would even begin to back port fixes into old versions, but maybe they do. If so, it'll be paid-for services though. If that is acceptable to your company, you might try contacting them.

    (edit: if you do find any pattern with the objects that bring up the error, you might of course also be able to discover the underlying reasons for the error, and maybe that will lend itself to some workarround. Not saying it's not a possibility - just saying that Automic support will, in my experience, not be inclined at all to assist you further with this once they dug out a change log entry that suggest the issue may be fixed in a later version).

    Cheers,
    Carsten




  • 7.  RE: Frequent Errors / Warning Messages using Automic Web Interface

    Posted 16 days ago
    Hi, Vendor has asked to upgrade AWI to 12.3 & closed the ticket. 
    However i am thinking to use AUTOMIC THICK CLIENT interface & see if we are facing the same issues or not.

    Since we are not in position to upgrade so i think AUTOMIC THICk CLIENT is good option to explore & try. 

    The only confirmation i need to get is if Vendor is still supporting or providing THICK client utility to partners/clients what i heard that thick client is not supportable from version 12.3, since we are version 12.0, so i believe we are good to use THICK client instead of web interface.

    Any thoughts on that.


  • 8.  RE: Frequent Errors / Warning Messages using Automic Web Interface
    Best Answer

    Posted 14 days ago
    Dear Sunsih,

    Version 12.0 is not the greates Version to stick with. I'd rather upgrade to at least 12.2 - that's the version we have right now and started with 12.0 in 2017. We had many issues with version 12.0 even though we just started to develop our workflows and did not have huge requirements. There are some very good improvements in 12.3 and with this release you don't need the java client (I guess that's what you call THICK client) any more. AWI might be unfamiliar in the first place, but really, the change is worth it.



    ------------------------------
    Regards, Nicole
    ------------------------------



  • 9.  RE: Frequent Errors / Warning Messages using Automic Web Interface

    Posted 13 days ago
    ​Hi Sunish,

    The Java client (aka Fat Client) works with 12.0. I'm not entirely sure if it's officially supported  by Automic for use with that release (i.e. for receiving support on it), but it did operate just fine.

    I think they dropped it with 12.1.x. There were some versions (and likely all releases since then) around that where the fat client plainly refused to connect to the engine because it became incompatible (due to new password hashes), so that's when you need to switch to AWI.

    As @Nicole Boeger pointed out, 12.0 had functional issues. Most people quickly moved on to at least 12.1 or 12.2, and I'd argue that even 12.2 still has several issues and if you do upgrade, aim to go to 12.3 instead and be prepared to move on once new releases show up. Going to 12.3 instead of 12.2 isn't a much more complicated upgrade, but saves you from a (surprisingly, to me) serious retraining requirement, in that 12.3 has overhauled the way tabs in AWI work.

    As for whether AWI is worth it, well ... several things about it are, some aren't. You certainly need more screen estate, it's decidedly less fun if your users have small notebook screens. But it's the future either way, and since support for 12.0 will end some day. And as you are already experiencing Automic is, let's say, somewhat selective in the way they support various issues with versions that aren't bleeding edge. Thus, I'd also suggest at least seriously looking into the possibility of upgrading.

    Cheers,
    Carsten​​