Automic Workload Automation

Expand all | Collapse all

JWP/JCP orai18n.jar error when setting SAML flag to Y... no matter what I try!

Jump to Best Answer
  • 1.  JWP/JCP orai18n.jar error when setting SAML flag to Y... no matter what I try!

    Posted 09-29-2020 12:46 PM

    Running 12.3.2 Automation Engine, Oracle 19c DB, 12.2.0.1.0 JDBC Driver and Oracle 12.2.0 instantclient.

    When I start the JWP, it all appears fine until I try to set the SAML flag to 'Y' so I can set up authentication. The error I get is below. Please let me know any other details needed. I've tried other versions of JDBC and the instantclient, I've tried setting the classpath in the start string in the uc4.smd file, I've got the classpath set as an environment variable to the directory that includes the orai18n.jar file, I checked that the character set in the DB matches WE8ISO8859P15 (it does), and I'm out of ideas. I've googled and googled and tried everything I could find to try. Ideas????

    20200929/100124.613 - 39 U00011847 'SAML' set to 'Y'.
    ...
    20200929/100126.453 - 37 U00003590 UCUDB - DB error: '99999', 'Non supported character set (add orai18n.jar in your classpath): WE8ISO8859P15', '17056', 'java.sql.SQLException'
    20200929/100126.456 - 37 SQL Statement which caused this DB error:
    20200929/100126.457 - 37 U02012075 Set bind parameter '1' of type 'Integer' to value '50038'
    20200929/100126.458 - 37 U02012075 Set bind parameter '2' of type 'XMLType' to value 'oracle.xdb.XMLType@4a85ffc5'
    20200929/100126.460 - 37 U02012075 Set bind parameter '3' of type 'String' to value '*SP'
    20200929/100126.461 - 37 INSERT INTO OVW (OVW_OH_Idnr,OVW_ValueX,OVW_VValue) VALUES (?,?,?)
    20200929/100126.463 - 37 U00045014 Exception 'com.automic.database.api.DBException: "INSERT INTO OVW (OVW_OH_Idnr,OVW_ValueX,OVW_VValue) VALUES (?,?,?)"' at 'com.automic.database.impl.DBConnectionImpl.executeInternal():467'.
    20200929/100126.466 - 37 U00045015 The previous error was caused by 'java.sql.SQLException: "Non supported character set (add orai18n.jar in your classpath): WE8ISO8859P15"' at 'oracle.sql.CharacterSetUnknown.failCharsetUnknown():231'.



  • 2.  RE: JWP/JCP orai18n.jar error when setting SAML flag to Y... no matter what I try!

    Broadcom Employee
    Posted 30 days ago
    Edited by Tatjana Radic 30 days ago
    Hi @Michelle Wood 
    You will need the Oracle Libs mentioned in the documentation:
    https://docs.automic.com/documentation/webhelp/english/AA/12.3/DOCU/12.3/Automic%20Automation%20Guides/help.htm#Installation_Common/SetUp_SAML_SSO.htm

    Oracle DB only: To ensure that the JWP processes XML variables correctly, you have to copy the files orai18n.jar, xdb6.jar and xmlparserv2.jar to the lib folder of the JWP. The files are either part of the database or can be downloaded from the Oracle SQL Developer site.


    ------------------------------
    Product Manager - Automation
    CA Technologies, A Broadcom Company
    ------------------------------



  • 3.  RE: JWP/JCP orai18n.jar error when setting SAML flag to Y... no matter what I try!

    Posted 29 days ago
    Edited by Michelle Wood 29 days ago

    I have tried copying and symlinking those files in the bin/lib directory under the engine (as well as the ojdbc8.jar file). Neither works and results in the above error.
    I've used package versions from yum repos as well as downloaded tars direct from oracle to get the jdbc jar files and all return this error (except jdbc 10, which doesn't seem to work at ALL).

    I also get this when trying to manually start the JWP with command line:

    File 'orai18n.jar' cannot be interpreted as jdbc driver because 'META-INF/services/java.sql.Driver' cannot be found.

    Why is it trying to load orai18n.jar as the driver instead of the ojdbc8.jar?




  • 4.  RE: JWP/JCP orai18n.jar error when setting SAML flag to Y... no matter what I try!
    Best Answer

    Posted 29 days ago

    Appears to have been resolved with symlinks to the following extracted to the /usr/java/latest/lib folder (I had hoped symlinks would work, they do... but apparently only this one specific ojdbc package set works for our environment): https://www.oracle.com/database/technologies/appdev/jdbc-ucp-19-6-c-downloads.html

    Thank you for your help!