Automic Workload Automation

Expand all | Collapse all

#FOKUS - Error upgrading AWA 11.2.x to 12.2.4 (Orcale 11G / SLES 11 SP4) libclntsh.so.12.1 => not found

Jump to Best Answer
  • 1.  #FOKUS - Error upgrading AWA 11.2.x to 12.2.4 (Orcale 11G / SLES 11 SP4) libclntsh.so.12.1 => not found

    Posted 11-08-2019 08:14 AM

    Error upgrading AWA 11.2.x to 12.2.4


    Hello AWA Community and feller Fokus Members,
    We have some issues while upgrading on a fresh cloned Automation engine Environment version 11.2.x. (From Production - AE 11.2.1 Oracle Database 11g on SLES 11 SP4)

     

    we had issue loading the tables into the Oracle Database with the DBLoad Utility.

    See this Log:


    20191108/125735.412 - U00033103 Automation Engine - Utilities Version 12.2.4+build.1569228673716 @ t1uc4 20191108/125737.628 - U00038017 File read: '../db/' 20191108/125745.061 - U00038017 File read: '/opt/uc4/utilities/db/general/12.2/UC_UPD.TXT' 20191108/125745.061 - U00038091 Change application directory to '../db/'. 20191108/125745.061 - U00038091 Change application directory to '../db/'. 20191108/125745.061 - U00038091 Change application directory to '/opt/uc4/utilities/bin'. 20191108/125745.061 - U00029120 UCUDB: Function LoadLibrary failed. Library 'ucuoci.so' error 'libclntsh.so.12.1: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden'. 20191108/125745.061 - U00003531 UCUDB: Error while checking data source (e.g. code conversion or driver problem, see log file). 20191108/125745.062 - U00003531 UCUDB: Error while checking data source (e.g. code conversion or driver problem, see log file).

     

     

    After troubleshooting we discovered that the lib is missing libclntsh.so.12.1 so we checked with a command: ldd on the desired machine, this is the output:

     

    V12.2.4

    [uc4@******* /opt/uc4/utilities/bin]$ ldd ucuoci.so

                    linux-vdso.so.1 =>  (0x00007ffeb7139000)

                    libsysapi.so => ./libsysapi.so (0x00007f995a50b000)

                    libzu00132.so => ./libzu00132.so (0x00007f995a2da000)

                    libuc001.so => ./libuc001.so (0x00007f995a0d5000)

                    libclntsh.so.12.1 => not found

                    libdl.so.2 => /lib64/libdl.so.2 (0x00007f9959ed1000)

                    libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f9959cb4000)

                    libstdc++.so.6 => ./libstdc++.so.6 (0x00007f9959ac4000)

                    libm.so.6 => /lib64/libm.so.6 (0x00007f9959849000)

                    libgcc_s.so.1 => ./libgcc_s.so.1 (0x00007f995aa04000)

                    libc.so.6 => /lib64/libc.so.6 (0x00007f99594cd000)

                    librt.so.1 => /lib64/librt.so.1 (0x00007f99592c4000)

                    /lib64/ld-linux-x86-64.so.2 (0x00007f995a925000)

     

     

    V12.2.1

    [uc4@***** /opt/uc4/utilities_v12.2.1/bin]$ ldd ucuoci.so

                    linux-vdso.so.1 =>  (0x00007fff98dcf000)

                    libsysapi.so => ./libsysapi.so (0x00007fbabe6e8000)

                    libzu00132.so => ./libzu00132.so (0x00007fbabe4b7000)

                    libuc001.so => ./libuc001.so (0x00007fbabe2b2000)

                    libclntsh.so.11.1 => /opt/oracle/product/11.2.0/dbhome_1/lib/libclntsh.so.11.1 (0x00007fbabb8f9000)

                    libdl.so.2 => /lib64/libdl.so.2 (0x00007fbabb6f5000)

                    libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fbabb4d8000)

                    libstdc++.so.6 => ./libstdc++.so.6 (0x00007fbabb2e8000)

                    libm.so.6 => /lib64/libm.so.6 (0x00007fbabb06d000)

                    libgcc_s.so.1 => ./libgcc_s.so.1 (0x00007fbabebe1000)

                    libc.so.6 => /lib64/libc.so.6 (0x00007fbabacf1000)

                    librt.so.1 => /lib64/librt.so.1 (0x00007fbabaae8000)

                    libnnz11.so => /opt/oracle/product/11.2.0/dbhome_1/lib/libnnz11.so (0x00007fbaba71b000)

                    libnsl.so.1 => /lib64/libnsl.so.1 (0x00007fbaba503000)

                    libaio.so.1 => /lib64/libaio.so.1 (0x00007fbaba301000)

                    /lib64/ld-linux-x86-64.so.2 (0x00007fbabeb02000)

      

    We had with Automic, a case open where the engineer ensured us that the Oracle version 11g is supported by any 12.2.x version.

     

    BTW: in the Community there is some information that this was a bug and had to be fixed with version 12.2.4 https://community.broadcom.com/enterprisesoftware/communities/community-home/digestviewer/viewthread?MessageKey=2510ede3-0283-454e-a75d-73518a81ca54&CommunityKey=2e1b01c9-f310-4635-829f-aead2f6587c4&tab=digestviewer


    Anyone got a hint for us?

     



    ------------------------------
    Eisa Heinig
    Fachkreisreferent
    IT System Engineer / Application Operator
    uniVersa Lebensversicherung a.G.
    Germany, Nuremberg
    ------------------------------


  • 2.  RE: #FOKUS - Error upgrading AWA 11.2.x to 12.2.4 (Orcale 11G / SLES 11 SP4) libclntsh.so.12.1 => not found

    Posted 11-08-2019 08:49 AM
    Hi Eisa,

    I know it is a little bit dirty, but did you try to create a soft link that point to the old version?

    ln -s /opt/oracle/product/11.2.0/dbhome_1/lib/libclntsh.so.11.1 /opt/uc4/utilities/bin/libclntsh.so.12.1

    Best regards,
    Tim

    ------------------------------
    Automation Evangelist
    Fiducia & GAD IT AG
    ---
    Mitglied des deutschsprachigen Automic-Anwendervereins FOKUS e.V.
    Member of the German speaking Automic user association FOKUS e.V.
    ------------------------------



  • 3.  RE: #FOKUS - Error upgrading AWA 11.2.x to 12.2.4 (Orcale 11G / SLES 11 SP4) libclntsh.so.12.1 => not found

    Posted 11-08-2019 09:05 AM

    Hey Tim,
    Thank you for your quick reply.


    In a worse case I could do this dirty hack, but I'm concerned opening more holes with this solution and must fix even more issues.

    I opened a Ticket and will have to wait desperately.

    Hopefully Automic did not decide to this " AE 12.2.x = Oracle 12 >"

     

    Have a Great Weekend.

    B.R

    Eisa



    ------------------------------
    Eisa Heinig
    Fachkreisreferent
    IT System Engineer / Application Operator
    uniVersa Lebensversicherung a.G.
    Germany, Nuremberg
    ------------------------------



  • 4.  RE: #FOKUS - Error upgrading AWA 11.2.x to 12.2.4 (Orcale 11G / SLES 11 SP4) libclntsh.so.12.1 => not found

    Posted 11-08-2019 09:19 AM
    Hi.

    I had the same problem some time ago. Automic has told me at the time that they always build against the latest supported Oracle client (but if you get a different answer, that's not exactly unexpected and would be good to know).

    While parts of the product may still support Oracle 11, the utilities require an installaton of an Oracle client v12. For that reason, I have Oracle 11 and Oracle 12 clients installed side by side, and my Automic utilities reference the libraries from the oracle client 12 (via LD_LIBRARY_PATH).

    This works fine.

    I strongly discourage symlinking between different shared objects and instead encourage you to install an Oracle client v12. Oracle supports using a client v12 even with their database v11:



    As for the very valid question what "supported" actually means for Automic, I have come to the conclusion that one must agree to disagree on the meaning of the term itself, as Automic defines the word in stark contract to what most of it's customers understand from it.

    Hth,
    Carsten


  • 5.  RE: #FOKUS - Error upgrading AWA 11.2.x to 12.2.4 (Orcale 11G / SLES 11 SP4) libclntsh.so.12.1 => not found

    Posted 11-08-2019 10:06 AM
    Hi Eisa,
    According to the compatibility matrix, 12.2.4 requires Oracle 12c
    https://downloads.automic.com/tools/compatibility_matrix?compatibility-mode=component&offering_version_id=1556109560944&lifecycle_entity_id=1409143059253

    ------------------------------
    Best regards,
    Thierry

    Banque de Luxembourg
    ------------------------------



  • 6.  RE: #FOKUS - Error upgrading AWA 11.2.x to 12.2.4 (Orcale 11G / SLES 11 SP4) libclntsh.so.12.1 => not found

    Posted 11-08-2019 02:40 PM
    Sorry to be the breaker of bad news but we also went thru this same situation. I have been told specifically that Broadcom only supports Oracle 11g to version 12.1.X.  Anything above require at least Oracle 12c.


  • 7.  RE: #FOKUS - Error upgrading AWA 11.2.x to 12.2.4 (Orcale 11G / SLES 11 SP4) libclntsh.so.12.1 => not found

    Posted 11-12-2019 04:01 AM

    Thank you for the reply,
    We had couple month ago an different statement from Automic support, but anyhow the respond from the Support today was totally in a different direction "ROFL"



    Hi Eisa,

    I have checked the details. And could see the error details as below.

    " U00003531 UCUDB: Error while checking data source "

    Can you please Utilize the Oracle 64-bit client instead of the 32-bit client. 

    Regards,
    Sneha

    I even don't know what to respond to this qualified answer :D



    ------------------------------
    Eisa Heinig
    Fachkreisreferent
    IT System Engineer / Application Operator
    uniVersa Lebensversicherung a.G.
    Germany, Nuremberg
    ------------------------------



  • 8.  RE: #FOKUS - Error upgrading AWA 11.2.x to 12.2.4 (Orcale 11G / SLES 11 SP4) libclntsh.so.12.1 => not found
    Best Answer

    Posted 11-14-2019 03:29 AM
    Edited by Eisa Heinig 11-19-2019 10:02 AM

    After complete ignoring reply to support, i got a straight forward statement :D



    Hi Eisa,

    AWA v12.2.4 is not compatible with Oracle 11

    we don't support v12.2.4 on Oracle v11

    Please check below document for Upgrading an AE System from Version 11.2 to Version 12.2

    https://docs.automic.com/documentation/webhelp/english/AWA/12.2/DOCU/12.2/AWA%20Guides/help.htm#Installation_Upgrade/install_upgrade_v112.htm%3FTocPath%3DInstalling%7CUpgrade%2520Installation%7CUpgrading%2520an%2520Automation%2520Engine%2520System%2520Manually%7C_____3

     

    Regards,
    Sneha



    ------------------------------
    Eisa Heinig
    Fachkreisreferent
    IT System Engineer / Application Operator
    uniVersa Lebensversicherung a.G.
    Germany, Nuremberg
    ------------------------------



  • 9.  RE: #FOKUS - Error upgrading AWA 11.2.x to 12.2.4 (Orcale 11G / SLES 11 SP4) libclntsh.so.12.1 => not found

    Posted 11-15-2019 09:33 AM
    After complete ignoring reply to support, i got a straight forward statement :D

    But how did you get that statement out of them? Were I to ignore their requests for the third set of logs, the next reiteration of what I already told them, or the performing of the ritual of dancing arround the AE server wearing nothing but a toga and a necklace made out of dead frogs, they'd just close my case and be done with it :(

    I even don't know what to respond to this qualified answer :D

    I also haz no words. I find alcohol can work. Happy weekend! ;)


    ------------------------------
    I will not respond to PM asking for help unless there's an actual reason to keep the discussion off of the public forums.
    ------------------------------