Automic Workload Automation

Expand all | Collapse all

Transport from higher to lower UC4 version

Jump to Best Answer
  • 1.  Transport from higher to lower UC4 version

    Posted 01-22-2020 04:45 AM
    Hi Team,

    can some one please confirm if we can transport objects from Higher UC4 version to Lower UC4 version? If yes, how this can be done? xml or dbload or any other method

    Many thanks in advance.


  • 2.  RE: Transport from higher to lower UC4 version

    Posted 01-22-2020 01:18 PM
    Edited by Pete Wirfs 01-22-2020 01:18 PM
    I think I used the xml method once.  I had to edit the xml file with notepad and modify the version information so that the lower UC4 would accept it.  (I sometimes use this trick when importing code that people have posted in these forums too.)

    If there are higher features being used in the transferred objects, I suspect they would probably be ignored by the import into the lower.  So you can't be sure it will load everything you expect it to.

    ------------------------------
    Pete
    ------------------------------



  • 3.  RE: Transport from higher to lower UC4 version
    Best Answer

    Posted 29 days ago
    In my knowledge the transport case from an higher version cannot be loaded in a lower version, there is some internal checks of the transport file first and there is somewhere a reference to the version of the DB used when generating the file.

    For XML, it is effectively possible to change the tag with the version number in the file.xml. Just be careful that some objects are quite different between a version 12.3 and a version 9 i.e. =-). Normally unknown tags are simply ignored but this may also generate an error during the import process sometime if there is an incompatible structure modification.

    Regards.

    Alain