Automic Workload Automation

Expand all | Collapse all

SOAP XML Request

Harriet_Kim_176401-18-2018 09:31 AM

Ben Sumner01-18-2018 05:07 PM

  • 1.  SOAP XML Request

    Posted 01-16-2018 04:37 PM
    Hi,
    I've successfully been using SOAP using the request object and filling out the required arguments.

    Now I need to add the XML globalVariables dynamically. The variables change with each run. 

    If I enter the details in the object section then click the XML button. It comes back with an error "Unable to build soap envelope for a multi argument web service method"

    This is the raw XML SOAP request (actual values removed) that is produced when I don't try and manually define the XML request:

    <?xml version="1.0" encoding="UTF-8"?>
    <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
      <soapenv:Header>
        <ns1:session soapenv:mustUnderstand="0" xmlns:ns1="http://www.businessobjects.com/DataServices/ServerX.xsd">
          <SessionID>Some session id</SessionID>
        </ns1:session>
      </soapenv:Header>
      <soapenv:Body>
        <ns1:RunBatchJobRequest xmlns:ns1="http://www.businessobjects.com/DataServices/ServerX.xsd">
          <jobName>Job name</jobName>
          <repoName>Job repo</repoName>
          <jobServer>Job server</jobServer>
          <jobParameters>
            <usecollectedstats>true</usecollectedstats>
          </jobParameters>
          <globalVariables>
            <variable name="G_BUSINESS_DATE">12-Jan-2018</variable>
            <variable name="G_RUN_NO">0</variable>
          </globalVariables>
        </ns1:RunBatchJobRequest>
      </soapenv:Body>
    </soapenv:Envelope>

    When I enter the SOAP request into the XML section I can't get it to work. 

    What parts of raw XML request need to be added? I've chopped and changed parts but can't get it to work.

    Cheers 
    Ben


  • 2.  SOAP XML Request

    Posted 01-16-2018 04:47 PM
    Hi BenSumner612127,
    This was a known issue that was fixed in RA Webservice SOAP solution version 4.1.0.

    Here is the KE article for it:  https://automic.force.com/support/apex/CommunityArticleDetail?id=ka3b0000000kCKZ

    Which version of the RA WS SOAP solution are you using?



  • 3.  SOAP XML Request

    Posted 01-16-2018 04:54 PM
    Thanks for the response - I'm on 3.1.0+build.1 
    Time to upgrade!!


  • 4.  SOAP XML Request

    Posted 01-16-2018 05:26 PM
    Harriet_Kim_1764
    Looking at the downloads section. The RA Web Service listed for 11.2 is 3.3.0.
    It looks like from 12.0 on wards the RA Web Service has been split into SOAP and REST. 
    RA Web Service SOAP 4.2.0
    Do you know if the above has been tested with 11.2? As we're not quite ready to upgrade to 12.


  • 5.  SOAP XML Request

    Posted 01-17-2018 11:12 AM
    Hi BenSumner612127,

    Unfortunately, the RA Web Service SOAP 4.2.0 is not compatible with v11.2.  It must be used, at the minimum, version 12.0 per this Compatibility Matrix results.

    Do you have a Test environment available where you can test RA Web Service solution 3.3.0?

    If upgrading to that version does not resolve the issue, then please open a ticket with Support with details why you can't upgrade to v12 and how this impacts your business.  Thanks!




  • 6.  SOAP XML Request

    Posted 01-17-2018 04:27 PM
    Thanks Harriet_Kim_1764

    RA Web Service solution 3.3.0 only contained a jar file. Am I also required to upgrade the RA Core? If so, what version?


  • 7.  SOAP XML Request

    Posted 01-17-2018 05:48 PM
    Hi BenSumner612127,
    You have to load the jar file into the Database using the AE DB Load utility tool.  Here's instructions how to upgrade your RA WS agent.  It's not required to upgrade the RA Core as long as it's, at least, the same version level as your AE.  Is your RA Core on version 11.2.x?


  • 8.  SOAP XML Request

    Posted 01-17-2018 06:04 PM
    Hi Harriet_Kim_1764
    Looks like it's older - 10.0.5


  • 9.  SOAP XML Request

    Posted 01-18-2018 09:31 AM
    Hi BenSumner612127
    Is your AE also on v10.0.5?


  • 10.  SOAP XML Request

    Posted 01-18-2018 05:07 PM
    Hi Harriet_Kim_1764

    No AE is on v11.2.2


  • 11.  SOAP XML Request

    Posted 01-18-2018 05:16 PM
    The next release of the RA Web Service Soap agent (4.3.0) will also work with 11.2.n
    The tentative release date is 1/31/2018.


  • 12.  SOAP XML Request

    Posted 01-18-2018 05:51 PM
    The next release of the RA Web Service Soap agent (4.3.0) will also work with 11.2.n
    The tentative release date is 1/31/2018.
    Hi BenSumner612127,
    If you are able to, you can wait when the RA WS Soap agent v4.3.0 is released per Alexander_Trenker_120's suggestion since it is compatible with v11.2.x.  It is our new native RA WS agent - where we developed our own libraries and no longer using Apache's Axis2 libraries.


  • 13.  SOAP XML Request

    Posted 01-19-2018 10:22 AM
    BenSumner612127 - I'd like to add that since your current RA core is on version 10.0.5, you should upgrade that to the v11.2 latest build version, apply the latest v3.3.0 solution, and test if that resolves the issue.  This is just a suggestion in case you didn't want to wait for the v4.3.0 solution.


  • 14.  SOAP XML Request

    Posted 01-21-2018 04:42 PM
    Harriet_Kim_1764 - Thanks for the suggestion. I'm happy to wait as I will be on annual leave until the v4.3.0 solution is released.



  • 15.  SOAP XML Request

    Posted 04-08-2018 07:22 PM
    Harriet_Kim_1764 - I waited for the 4.3.0 solution to be released. Updated the RA Core to 11.2.1. Got the Web Services SOAP agent working as expected but after completing all of my development ran into an bug java.lang.StringIndexOutOfBoundsException: String index out of range: 4 (https://automic.force.com/support/apex/CommunityArticleDetail?id=ka3b0000000fysZ)

    I believe that that was resolved in 11.2.3?

    We're not in a position to upgrade at the moment. Are you aware of any patches or work arounds that can be applied to get around this until we can upgrade? 

    I've tried re-installing the Web Service SOAP agent and deleting the cache but nothing as worked so far,

    Any help is much appreciated.