Automic Workload Automation

Expand all | Collapse all

C_Period in v11.2.5 sometimes doesn't come out of sleep

  • 1.  C_Period in v11.2.5 sometimes doesn't come out of sleep

    Posted 10-09-2017 08:43 PM
    Has anyone noticed an issue with c_period executions where the c_period gets stuck in a sleep mode and doesn't wake up again until I Stop and Go the c_period? I've noticed it happening when the previous c_period runs over the Midnight time frame. But it's not on every c_period. And I haven't been able to reproduce it on demand to submit a bug, but I have seen it a few times.

    This example c_period runs With a Gap of 1 hour, but it hasn't run since 6 Oct. The user informed me of this issue, and I did a Stop/Go on the c_period.

    2222pehomxsj.pngb8oiwvst1usp.pnghttps://us.v-cdn.net/5019921/uploads/editor/3s/b8oiwvst1usp.png" width="964">



  • 2.  C_Period in v11.2.5 sometimes doesn't come out of sleep

    Posted 10-10-2017 01:47 AM
    Hi SamahSohrab607228 ,

    Good news for you - this was already identified as a bug and is/will be fixed in the following versions:

    Periodic task does not work any more after period log-change

    An error has been fixed where a periodic task did not work any more after a period log-change. If a periodical task with mode "GAP" is started at the same time as the period starts a task, based on the timing, the parent of the child task might be wrong and the period is not reset after the child ended. Therefore the periodic task will not start any new tasks.
    Components:
    • AutomationEngine
    Fixed Versions:

    Automation.Engine 12.1.0
    Automation.Engine 12.0.3
    Automation.Engine 11.2.6

    The tentative release date for 11.2.6 is: 10/23/2017

    Affected component: Automation Engine

    Cheers,
    Alexander