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Tech Tip: Agile Designer Automator: No valid license found when using with Agile Designer license

  • 1.  Tech Tip: Agile Designer Automator: No valid license found when using with Agile Designer license

    Posted Oct 20, 2017 01:22 PM

    This document can also be viewed at https://support.ca.com/us/knowledge-base-articles.TEC1921426.html.

    For more documents like this, visit our knowledge base here- CA Agile Requirements Designer

    Issue:

    I have just installed Agile Requirements Designer (ARD) and Agile Designer Automator (ADA) from the 2.5 GA release. When launching ADA, I am receiving a 'No valid license found' error message. ARD launches fine and it is pointed to a license server where we have concurrent licenses activated. On another system, we are running an older version of ARD and ADA. They are pointed at the same concurrent license server and are both running fine.

    Environment:
    CA Agile Requirements Designer (ARD)- Agile Designer + Agile Designer Automator (ADA)- Javelin
    Cause:

    This issue will only occur with the GA release of ARD 2.5 (and the ADA build that comes installed with it) and concurrent licenses. ADA should be able to launch if you have a valid workgroup or automation builder license installed with ARD. If you were able to launch ARD, then you have a valid license installed. Unfortunately, what is happening is ADA is checking for named user licensing and since it does not find that because you have concurrent licensing, ADA is refusing to start and saying you have an invalid license. This is a known issue that development can provide a patch for if using ARD 2.5. 

     

    However, we highly suggest to stop using your ADA instance and start using the Javelin instance installed with Test Data Manager (TDM). The two builds have been merged and only Javelin will be developed moving forward.

    Resolution:

    The simplest solution is download TDM and use Javelin instead of ADA. If you cannot do this, please open a support case by going to https://support.ca.com/us.html and reference this knowledge document TEC1921426. Once support attaches the patch to the case, please follow these instructions for downloading and applying it. 


    To download: 
    1. Login to CA Support Online: https://support.ca.com/us.html 
    2. Click on the ‘Case Management’ icon.
    3. Look in your ‘My Cases’ tab or search for the support case number in the ‘Search Cases’ tab.
    4. Click on the ‘FTP/SFTP Access Information’ section.
    5. Login to supportftp.ca.com.
    6. To download the file from the case, use the following path: sftp://supportftp.ca.com/0100675/(case # here)/files_from_ca
    7. Click on the file you need to download. In this case, it is AgileDesignerAutomator-2.0.76.0.zip. 


    To apply: 
    1. Take a backup copy of your ADA directory folder. 
    2. Open the AgileDesignerAutomator-2.0.76.0.zip file. 
    3. Double click on the setup_ AgileDesignerAutomator_2.0.76.0.exe file to start the installation wizard. 
    4. Follow the steps in the installation executable to update ADA. 
    5. Re-open ADA. You should be able to open without error. 

    Additional Information:

    If you are receiving a 'No valid license was found' error in Javelin, please follow the steps in this document to resolve: https://support.ca.com/us/knowledge-base-articles.TEC1461131.html