DX Infrastructure Management

Expand all | Collapse all

net_connect hostname coming in alarm as IP

Jump to Best Answer
  • 1.  net_connect hostname coming in alarm as IP

    Posted 08-07-2019 09:02 AM
    So, I have net_connect default profile configuration for QoS and Alarm set all to Profile name for QoS identification, QoS Source, and Alarm identification.  However, on some profiles where the ping is failing, the hostname in the alarm console is being reported as the IP.  What could cause this and what is the solution to get the actual Profile Name to appear as hostname?

    default profile and profile settings for alarm and qos


  • 2.  RE: net_connect hostname coming in alarm as IP

    Posted 08-07-2019 09:28 AM
    Also, looking on the status window of the net_connect probe, the hostname is displayed there correctly so not sure why the alarm is showing IP as hostname


  • 3.  RE: net_connect hostname coming in alarm as IP
    Best Answer

    Posted 08-07-2019 09:44 AM
    Looks like this is actually the nas probe Name Services that is affecting this.  In nas probe Name Services, enabled Ignore Unsuccessful resolution attempts, deleted any entries in address table that had IP for name - will see what happens


  • 4.  RE: net_connect hostname coming in alarm as IP

    Posted 08-07-2019 10:02 AM
    Well that didn't work - looks like some probes just send source as IP and no way to configure to send hostname. Turned back on name services but disabled use default name resolution - still showing IP as hostname on some net_connect profiles that are failing ping.


  • 5.  RE: net_connect hostname coming in alarm as IP

    Posted 08-07-2019 10:42 AM
    Re-enabled the use default name resolution since that didn't make a difference in this case.  Looks like we are stuck having to edit nas Name Services address table for the hostnames being sent by net_connect that don't resolve. SMH, so disappointed


  • 6.  RE: net_connect hostname coming in alarm as IP

    Posted 08-07-2019 11:42 AM
    This was the answer - had to disable Use Default Name Resolution, remove any entries in Address Table that had IP for name, acknowledge old alarms to retrigger with hostname.  Cannot completely disable name services since some probes do not send hostname (send robotname as source which Name Services converts to hostname with the 'Use NMS robot name as hostname')