DX Infrastructure Management

Expand all | Collapse all

CABI 3.40 failed to start

Jump to Best Answer
  • 1.  CABI 3.40 failed to start

    Posted 11-26-2019 04:00 AM
    Hello,

    After installing cabi 3.40 and UMP 9.0.2 HF2, the probe cabi can't start anymore with the attached errors.
    I've indeed changed the default password and have already increased the memory to 2 GB

    Does someone have an idea what's wrong here and how to fix it ?

    Regards,
    Philong



  • 2.  RE: CABI 3.40 failed to start
    Best Answer

    Posted 11-26-2019 11:52 AM

    Philong -

    Did you also change the superuser password in the cabi.cfg file to match the new password you have set on the CABI server?  From the cabi log posted, the probe is failing to login to the cabi server because you do not have a valid password.  Try the following to see if this resolves the issue for you:

    1. From the cabi probe's Raw Configure GUI, select the setup folder from the left-hand pane, then Modify/Add the following key value in the right-hand pane:

      cabi_rest_password_cleartext = <clear text superuser password you set for the CABI server>

      Apply the change.

    2. Cold start (deactivate, then activate) the cabi probe.  The cabi_rest_password_cleartext key will be removed and the cabi_rest_password key value updated with the encrypted password from the clear text password that you entered.  This should get you past the probe failing to login to the CABI server on start up.


    ------------------------------
    Kathy Maguire
    Technical Support Engineer 4
    Broadcom
    ------------------------------



  • 3.  RE: CABI 3.40 failed to start

    Posted 12-05-2019 06:04 AM
    Hello Kathy,
    It's weird because I don't have this issue on two other sites !!

    I re-created a server with UIM 9.0.2 and UMP 9.0.2 and cabi 3.32 and all work OK but after deploying cabi 3.40, the probe could not get started and throws these errors.

    By the way, I've NOT changed the default password in CABI.

    Please help ...


    ...
    Dec 04 22:41:13:015 [main, cabi] request failed: (4) not found, Received status (4) on response (for sendRcv) for cmd = 'probe_config_get' name = 'wasp'Dec 04 22:41:13:015 [main, cabi] request failed: (4) not found, Received status (4) on response (for sendRcv) for cmd = 'probe_config_get' name = 'wasp'Dec 04 22:41:13:015 [main, cabi] (4) not found, Received status (4) on response (for sendRcv) for cmd = 'probe_config_get' name = 'wasp' at com.nimsoft.nimbus.NimSessionBase.sendRcv(NimSessionBase.java:622) at com.nimsoft.nimbus.NimSessionBase.sendRcv(NimSessionBase.java:573) at com.nimsoft.nimbus.NimClientSession.send(NimClientSession.java:173) at com.nimsoft.nimbus.NimRequest.sendImpersonate(NimRequest.java:264) at com.nimsoft.nimbus.NimRequest.sendImpersonate(NimRequest.java:237) at com.nimsoft.nimbus.NimRequest.send(NimRequest.java:208) at com.ca.cabi4uim.utilities.ProbeUtils.request1(ProbeUtils.java:383) at com.ca.cabi4uim.utilities.ProbeUtils.request(ProbeUtils.java:391) at com.ca.cabi4uim.utilities.ProbeUtils.waspConfigGet(ProbeUtils.java:234) at com.ca.cabi4uim.utilities.ProbeUtils.waspConfigGetAndHandleKeyNotFoundCondition(ProbeUtils.java:661) at com.ca.cabi4uim.utilities.ProbeUtils.isWaspSaaS(ProbeUtils.java:629) at com.ca.cabi4uim.Probe.setupcabi(Probe.java:368) at com.ca.cabi4uim.Probe.initOnTimer(Probe.java:698) at com.nimsoft.nimbus.NimProbe.doForever(NimProbe.java:418) at com.ca.cabi4uim.Probe.run(Probe.java:888) at com.ca.cabi4uim.Probe.main(Probe.java:120)
    Dec 04 22:41:14:671 [main, cabi] nimEx.getCode()=4, nimEx.getMsgForCode()=not found, nimEx.getMessage()=Received status (4) on response (for sendRcv) for cmd = 'probe_config_get' name = 'wasp'Dec 04 22:41:14:671 [main, cabi] ignoring the message as the key might not net set; logging it for tracking later Received status (4) on response (for sendRcv) for cmd = 'probe_config_get' name = 'wasp'Dec 04 22:41:14:674 [main, cabi] java.util.concurrent.TimeoutException: cabi webapp at 'http://10.5.0.4:80/cabijs' failed to start in 10 minutes at com.ca.cabi4uim.utilities.ProbeUtils.waitForWaspAndWebappToStartupCompletely(ProbeUtils.java:1713) at com.ca.cabi4uim.Probe.makeSureCabijsWebappIsUp(Probe.java:483) at com.ca.cabi4uim.Probe.createRestUser(Probe.java:620) at com.ca.cabi4uim.Probe.setupCabiInBundledMode(Probe.java:424) at com.ca.cabi4uim.Probe.setupcabi(Probe.java:351) at com.ca.cabi4uim.Probe.initOnTimer(Probe.java:698) at com.nimsoft.nimbus.NimProbe.doForever(NimProbe.java:418) at com.ca.cabi4uim.Probe.run(Probe.java:888) at com.ca.cabi4uim.Probe.main(Probe.java:120)
    Dec 04 22:41:14:674 [main, cabi] setting the lastInstallStatus=4Dec 04 22:41:14:674 [main, cabi] successfully set the lastInstallStatus=4Dec 04 22:41:14:675 [main, cabi] srcFilePath=C:\Program Files (x86)\Nimsoft\probes\service\cabi\cabi.log, srcFilePath.exists=true, tgtFilePath=C:\Program Files (x86)\Nimsoft\probes\service\cabi\cabi_install_archive.log, tgtFilePath.exists=trueDec  4 22:41:15:676 [4408] Controller: Probe 'cabi' (command = <startup java>) returns no-restart code (42)


  • 4.  RE: CABI 3.40 failed to start

    Posted 12-05-2019 06:14 PM
    Philong -

    The cabi 3.40 probe requires that you upgrade your UMP to the 9.02 HF2 first.  This can be downloaded from CnIa24uJ@ftp.ca.com/Important%20Hotfixes/UMP902_HF2/" onclick="dataLayer.push({'event': 'eventTracker', 'eventCat': 'outbound links', 'eventAct':'ftp.ca.com', 'eventLbl': 'uimuser:cnia24uj@ftp.ca.com/important%20hotfixes/ump902_hf2/', 'eventVal': 0, 'nonInteraction': 0});" target="_blank" rel="noopener">UMP902_HF2.  Did you do this by following the instructions found in the "CA Unified Infrastructure Management_ENU - UMP 9.0.2 Hotfix 2.pdf" on  UMP 9.02 HF2 download site to upgrade your UMP prior to running the 3.40 cabi install?  if not, and you cannot deploy the UIM 9.20 service pack then install the 4.10 cabi probe, then you will need to follow the instructions found in the KB97227 : CAUIM CABI - How to Uninstall / Reinstall Bundled CABI Knowledge Document, then run the UMP 9.0.2HF2 install instructions to upgrade your UMP before deploying the 3.40 cabi probe.

    If you have already deployed the UMP 9.0.2HF2 prior to installing the 3.40 cabi probe, then my recommendation would be to open a support case to look into this further.


    ------------------------------
    Kathy Maguire
    Technical Support Engineer 4
    Broadcom
    ------------------------------