DX Infrastructure Manager

Expand all | Collapse all

OC 20.3.2 doesn't auto refresh and LOGS OUT every f5

  • 1.  OC 20.3.2 doesn't auto refresh and LOGS OUT every f5

    Posted 7 days ago
    hi every one, i tried to find a solution with a support case but it takes too long and they don't have any sulotion.
    maybe someone here having this issue too.

    after upgrading to 20.3.2 our OC doesn't seems to auto-refresh (can't see new alarms), and when you refresh the browser (f5), the OC logs out and then you need to login again.
    this is bad, our NOC team can't see any new alarms and we are missing new critical alarms in our PRODUCTION !

    i have followed this doc:

    UIM 20.3 - Session timeout settings for Operator Console (OC)
    (12 hours expiry, 30 sec refresh interval)
    but it didn't help

    the support suggested:
    https://knowledge.broadcom.com/external/article?articleId=202536

    but still, the OC doesn't auto refresh every 30 sec interval. and when you refresh (f5) the chrome browser it log you out.

    please try to help us.
    thank you



  • 2.  RE: OC 20.3.2 doesn't auto refresh and LOGS OUT every f5

    Posted 6 days ago
    any onw have any suggestion?


  • 3.  RE: OC 20.3.2 doesn't auto refresh and LOGS OUT every f5

    Posted 6 days ago
    I followed the same article but it seems to be working for me.

    Here are the settings I use in my install:

    (Ignore the vertical line after the expiry, it is an artifact from my remote control utility)

    Restarted the wasp probe and everything took.
    Hitting F5 doesn't log me out just refreshes the Chrome tab.  I believe it did log me out on the default expiration setting though.


  • 4.  RE: OC 20.3.2 doesn't auto refresh and LOGS OUT every f5

    Posted 4 days ago

    we have configured config.properties to : 

    session.timeout=720
    session.timeout.warning=1
    session.timeout.auto.extend=true

    and our wasp.cfg to:

    https://api-broadcom-ca-user.wolkenservicedesk.com/attachment/get_attachment_content?uniqueFileId=vgbZRAEtPHg12oWbpHp3zA==

     

    oc.jwt.expiryinsecs 43200 = session.timeout 720 (min) = 12 hours

     

    but still, after a few minutes if we refresh our chrome the session of the oc is logged out




  • 5.  RE: OC 20.3.2 doesn't auto refresh and LOGS OUT every f5

    Posted 2 days ago
    ​How are the users setup? LDAP Group or Locally. I did have same issue with users coming through using some ldap groups but creating the same user locally helped with the auto refresh issue.
    I am working with support on it but its not going anywhere.


    ------------------------------
    Thanks
    ------------------------------



  • 6.  RE: OC 20.3.2 doesn't auto refresh and LOGS OUT every f5

    Posted yesterday
    HI Srini,
    First of all make sure that bus users and LDAP users dont share same ACL. I have a doubt that you have acl's being shared. Please try to change, this should fix the problem

    ------------------------------
    HCL Technologies
    ------------------------------



  • 7.  RE: OC 20.3.2 doesn't auto refresh and LOGS OUT every f5

    Posted yesterday
    hi, we use LDAP users, but i think it happens to local users too...
    support try to help me to.
    good to hear im not the only one


  • 8.  RE: OC 20.3.2 doesn't auto refresh and LOGS OUT every f5

    Posted yesterday
    I am saying In IM , if you have ACL's in security (Administrator , guest etc etc) , for LDAP user and bus users you must have different ACL's, You can not share an ACL "Administrator" or any with both LDAP and BUS users.
    So create a new ACL in IM and assign that to AD group only and make sure you never assign a BUS user to that ACL

    ------------------------------
    HCL Technologies
    ------------------------------



  • 9.  RE: OC 20.3.2 doesn't auto refresh and LOGS OUT every f5

    Posted 7 hours ago
    We have a similiar problem, but not such extensive. (Not that f5-press-thing)
    Sometimes our LDAP-User (AD to be exact) didnt get the refresh, even the blue ribbon doesnt appears, with local-Users (all, LDAP + local share the same ACL) there is no problem.
    Naturally we set expiryInSecs + refreshInterval etc. but doesnt help
    Well I opened a call with our support but doesnt work either, because I can not repoduce it, nor our support can. The error appears sometimes, ugly but happens, therefore we do not use LDAP-User at the momement, big fall back for us, Normally aprox 20 Users had the Consoloe open under UMP, but now only 5, cause I will not build all 20 Users local, who cant even change their passwords by themself ;-)
    Just crossing fingers that it will magically disappear if 20.3.3 comes out.

    cheers
    Matthias


  • 10.  RE: OC 20.3.2 doesn't auto refresh and LOGS OUT every f5

    Posted 5 minutes ago
    Again,
    the local users and LDAP user cant have same ACL , in below screen shot , if Admin is assigned to LDAP users and linked with AD group. You cant have local users that group assigned , otherwise you are going to get these frequent logout errors, it is explicitly mentioned in LDAP integration documents.

    and you dont need to create new local users. Just copy the ACL you have assigned to bus users and create new and LINK it to AD group




    Once new ACL is created go to "Set LDAP Group" and set the LDAP group where your users are asigned. And you do not require to create UMP/OC user to login webconsole.

    ------------------------------
    HCL Technologies
    ------------------------------



  • 11.  RE: OC 20.3.2 doesn't auto refresh and LOGS OUT every f5

    Posted 3 minutes ago
    Dont do anything thing in UMP/OC after setting up new ACL in IM for the LDAP group .

    ------------------------------
    HCL Technologies
    ------------------------------