DX Infrastructure Manager

Expand all | Collapse all

EC2 Hostname not visible in USM

Jump to Best Answer
  • 1.  EC2 Hostname not visible in USM

    Posted 06-01-2020 12:21 PM
    Hi All,

    we are monitoring aws resources using aws probe and also deployed agents on ec2 instances.
    But those ec2 instances are visible in USM portal with their DNS name(both in Name and Alias) and not the hostname.
    Also they do have DNS entries so that is not the problem.
    Let me know if anyone knows the reason behind this.

    Thanks
    Anmol


  • 2.  RE: EC2 Hostname not visible in USM

    Posted 06-01-2020 01:10 PM
    Hi,
    so it is unclear what the problem is you are facing.
    It sounds like you have robots installed on ec2 instances that are being monitored by AWS as well is this correct.
    Is the problem that the systems are coming in with DNS names from the robot instead of hostname only?
    If so you can set the controller on the robots so overwrite the automatic discovery of name.
    Clear the niscache folder on the systems.
    Go into USM inventory section and delete the two systems<( make sure NOT to check the options when asked)
    then restart the robots. they should then come in with just the robotname/hostname




    ------------------------------
    Gene Howard
    Principal Support Engineer
    Broadcom
    ------------------------------



  • 3.  RE: EC2 Hostname not visible in USM

    Posted 06-01-2020 02:48 PM
    Hi Gene,

    Yes both aws probe and robots are collecting data.
    As far as IM console is concerned, we are getting correct hostnames as name of the robot but these same robots are visible in USM with DNS names(like  ec2-ip-aws.com) of ec2 instances.
    Ideally we would like hostname to be visible in USM as well, currently we did overwrite alias manually and it worked but i need to know what is the reason causing this ?

    Thanks
    Anmol



  • 4.  RE: EC2 Hostname not visible in USM
    Best Answer

    Posted 06-01-2020 04:04 PM
    this will be an issue with discovery_server.
    See the below two topics
    http://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/ca-unified-infrastructure-management-probes/GA/alphabetical-probe-articles/discovery-server-discovery-server/device-correlation-configuration.html

    http://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/ca-unified-infrastructure-management-probes/GA/alphabetical-probe-articles/discovery-server-discovery-server/device-correlation-troubleshooting.html

    you might also want to look at:
    How do I force USM to use only shortnames when doing discovery? (Knowledge Base Articles - 34611)
    https://ca-broadcom.wolkenservicedesk.com/external/article?articleId=34611

    ------------------------------
    Gene Howard
    Principal Support Engineer
    Broadcom
    ------------------------------