DX Infrastructure Manager

Expand all | Collapse all

enhanced rsp 5.50 doesnt monitor all the chosen QoS

  • 1.  enhanced rsp 5.50 doesnt monitor all the chosen QoS

    Broadcom Employee
    Posted 10 days ago
    Edited by stefan_ 10 days ago
    does the rsp probe 5.50 configured via enhanced rsp mcs in OC 20.3.3 monitor and send all the configured metrics?

    i deployed rsp 5.50 and configured it in OC via enhanced rsp mcs, but it doesnt display/monitor all the chosen Qos.
    for example, from the cpu Qos it monitors and sends metrics only for QOS_CPU_USAGE and QOS_PROC_QUEUE_LEN although all these Qos was chosen to be montired in OC:
    CPU Average Total Usage
    CPU Average User Time
    CPU Average System Time
    Individual CPU Total Usage
    Individual CPU User Time
    Individual CPU System Time
    Individual CPU Wait Time

    in addition, QOS_PROC_QUEUE_LEN was NOT even chosen to be monitored, but it is monitored/sent/displayed in OC.

    tried on 2 different UIM (20.3.3) instances and troubleshooted with dr nimbus, where i can see that only for QOS_CPU_USAGE and QOS_PROC_QUEUE_LEN is QOS_DEFINITION sent.

    the plugin_metric.cfg contains "publish_qos = true" for all the metrics chosen in OC to be montiored and "publish_qos = false" for QOS_PROC_QUEUE_LEN (that is actaully monitored).

    how does the rsp 5.50 work in your environment please? and if it works fine, do you have please any idea what could cause the issue in our? i havent touched the rsp probe gui ( = manual rsp configuration).


    thank you,
    stefan


  • 2.  RE: enhanced rsp 5.50 doesnt monitor all the chosen QoS

    Broadcom Employee
    Posted 9 days ago
    will set it up in my lab and test.

    ------------------------------
    Support Engineer
    Broadcom
    NY
    ------------------------------



  • 3.  RE: enhanced rsp 5.50 doesnt monitor all the chosen QoS

    Broadcom Employee
    Posted 5 days ago
    Yes found the problem in my lab, investigating.

    ------------------------------
    Support Engineer
    Broadcom
    ------------------------------



  • 4.  RE: enhanced rsp 5.50 doesnt monitor all the chosen QoS

    Broadcom Employee
    Posted 5 days ago
    David, in that case please test 2 more things that doesnt work correctly either for me:
    1.  when the enhanced rsp is configured, it creates automatically an alarm policy as well.  however the alarm policy for the rsp in the plugin_metric.cfg contains "qos_target = ~.*", so in case that
    A) either more rsp profiles are configured for that rsp or
    B) the device/robot where the rsp probe is deployed has other probe as well, for instance cdm, this alarm policy rewrites the alarm (tresholds, etc) for other QoS as well.

    2. when you create a group and configure an rsp profile that group and after that you add a device(s) into that group and because of some reason you have to remove a device from the group, the rsp continues monitoring the device even it is NOT in the rsp device group anymore.

    so in my opinion, there are more problems with the enhanced rsp.

    if you found the same problems in your lab, please let me know, whether you can get in touch with the dev/product team and ask them to fix them. thank you.