DX Infrastructure Manager

Expand all | Collapse all

inst_pkg failed: communication error

  • 1.  inst_pkg failed: communication error

    Posted 02-20-2020 05:11 AM
    Hi ,

    I have followed the communities already for the same error but firewall is already turned off in our case and still we are facing the below error while trying to deploy probes on robot .

      inst_pkg failed: communication error



    Regards
    Amar


  • 2.  RE: inst_pkg failed: communication error

    Posted 02-20-2020 05:18 AM
    Hi ,




  • 3.  RE: inst_pkg failed: communication error

    Posted 02-20-2020 08:18 AM
    The same issue faced for me as well.

    Any suggestion?


  • 4.  RE: inst_pkg failed: communication error

    Posted 02-20-2020 08:31 AM
    so this is going to be a network /firewall issue.
    Most likely you have a robot attached to a secondary hub that you are trying to work with.
    The secondary hub has both a direct connection to the primary on port 48002 as well as a tunnel setup.
    we do not support this.
    Either you use tunnels and ONLY connect on the tunnel port 48003 OR you have everything open from 48002-48050 between ALL machines.

    The other possibility is that you have a NAT setup between your robot and your hub rather than having the hub on the same network as the hub.
    Again not a supported configuration.

    Without more details of IP address for the robot hub, hub tier structure, IE how the hub communicates with the primary etc this will be hard to help with
    You can use the probe utility PU call back from the primary to do a name to IP call back to find out the IP and port you are trying to connect on that use telnet to test and repeat the process on each hub until you find the problem communication link so that you can correct it.

    ------------------------------
    Gene Howard
    Principal Support Engineer
    Broadcom
    ------------------------------



  • 5.  RE: inst_pkg failed: communication error

    Posted 02-20-2020 01:32 PM
    if the target system is Windows 80040402 could be an error passed back from the OS.
    perhaps this will help:
    https://answers.microsoft.com/en-us/windows/forum/all/error-code-80040402-while-fix-troubleshooting/22c50f22-0af9-4204-bb53-8360560e7581

    ------------------------------
    Support Engineer
    Broadcom
    ------------------------------



  • 6.  RE: inst_pkg failed: communication error

    Posted 02-21-2020 12:00 AM
    Hi all ,

    The target system(robot) is having cent OS .

    The ports 48000 to 48050 are enabled between CA UIM and the target system(robot) and I have uninstalled the nimsoft agent and followed the nimldr utility based installation as well  but still I am not able to deploy the probe on the robot .



    Regards
    AMar


  • 7.  RE: inst_pkg failed: communication error

    Posted 02-21-2020 12:27 AM

    Hi ,

    i have  tried deploying the probe on that robot again and got these logs recorded in distrv :

    Feb 21 10:47:33:658 [29140] distsrv: license_check from hubip/55905

    Feb 21 10:47:40:832 [29140] distsrv: archive_list from hubip/56122

    Feb 21 10:47:40:862 [29140] distsrv: job_add from hubip/56126

    Feb 21 10:47:40:872 [29140] distsrv: unzip successful for: E:\Program Files (x86)\Nimsoft/archive/robot_update.zip

    Feb 21 10:47:44:927 [31132] distsrv: unzip successful for: E:\Program Files (x86)\Nimsoft/archive/robot_update.zip

    Feb 21 10:47:44:941 [31132] distsrv: start_install starting

    Feb 21 10:47:44:941 [31132] distsrv: Installation of robot_update on /NPCI_Domain/CHECAUIMHUB01_Pri_hub/hyclpcbivrdb01 started

    Feb 21 10:47:44:942 [23692] distsrv: checking ACLs

    Feb 21 10:47:44:945 [23692] distsrv: unzip - no files found for E:\Program Files (x86)\Nimsoft/archive/robot_update.zip

    Feb 21 10:47:44:970 [23692] distsrv: unzip successful for: E:\Program Files (x86)\Nimsoft/archive/robot_update.zip

    Feb 21 10:48:03:879 [23692] distsrv: nimSessionWaitMsg: got error on client session: 10054

    Feb 21 10:48:22:792 [23692] distsrv: nimSessionWaitMsg: got error on client session: 10054

    Feb 21 10:48:22:792 [23692] distsrv: inst_pkg failed: communication error

    Feb 21 10:48:23:146 [29140] distsrv: license_check from hubip/56708

    Feb 21 10:48:23:147 [20776] distsrv: Installation of robot_update on /Domain/Primaryhub/robotname finished

    Feb 21 10:48:23:147 [20776] distsrv: Recording finishing status of installation of robot_update on /Domain/Primaryhub/robot

    Regards
    AMar




  • 8.  RE: inst_pkg failed: communication error

    Posted 02-21-2020 04:46 AM
    Hi all ,

    Can someone reply please .

    Regards
    AMar


  • 9.  RE: inst_pkg failed: communication error

    Posted 02-21-2020 09:25 AM
    At least to me this is next to meaningless:
    The ports 48000 to 48050 are enabled between CA UIM and the target system(robot)

    Reason is 'CA UIM' could mean any number of things.
    To ensure connectivity:
    remote into the hub that has this robot and telnet <robot ip address>:48000
    remote into the hub that has this robot and telnet <robot ip address>:48002
    remote into the robot and telnet <hub ip address>:48000
    remote into the robot and telnet <hub ip address>:48002

    As it turns out there is more than one revision of CentOS so it is left up to you to check the compatibility matrix and ensure it is supported.

    FYI responding here is no ones job, for those that do, they are taking time away from their responsibilities to help others out here. Point is that a response is not based on your time line but that of those that do choose to help. 


    ------------------------------
    Support Engineer
    Broadcom
    ------------------------------



  • 10.  RE: inst_pkg failed: communication error

    Posted 02-24-2020 12:25 AM
    Hi David ,

    I understand how busy you people are , but in this case telnet is happening between robot and hub on 48002 and hub and robot on 48000 .

    Cent os compatability need to be checked . But , we have PR and DR set up of same cent os and one was working fine and the other we are facing this issue and so the awaited for the experts help .

    Regards
    AMar


  • 11.  RE: inst_pkg failed: communication error

    Posted 02-24-2020 08:50 AM

    Amar -

    From the posted distsrv logs, you are seeing a 10054 winsock error when the distsrv attempts communicating with this robot.  Here is the description of the 10054 winsock error:

    Connection reset by peer.

    An existing connection was forcibly closed by the remote host. This normally results if the peer application on the remote host is suddenly stopped, the host is rebooted, the host or remote network interface is disabled, or the remote host uses a hard close (see setsockopt for more information on the SO_LINGER option on the remote socket). This error may also result if a connection was broken due to keep-alive activity detecting a failure while one or more operations are in progress. Operations that were in progress fail with WSAENETRESET. Subsequent operations fail with WSAECONNRESET.

    Do you have SELinux enabled on the remote robot?
    Are you running any Anti-Virus software on this system which might be causing the communication error?
    Have you gone through Gene Howard's complete posting and verified that you are not encountering any of the conditions he outlines in his update?  (is the robot managed by a secondary hub with a tunnel connection, etc)



    ------------------------------
    Kathy Maguire
    Technical Support Engineer 4
    Broadcom
    ------------------------------



  • 12.  RE: inst_pkg failed: communication error

    Posted 02-24-2020 09:06 AM
    Verify there is no firewall or firewalld process running on the robot and that the /etc/hosts has the correct IP for itself and one entry for itself which is consistent with UIM. Run nslookup's on robot verifying correct IP for itself and hub.

    Did you say, from robot: telnet hub 48000; telnet hub 48002 and from hub telnet robot 48000; telnet robot 48002, worked? I doubt it would as that error is basically saying it can't communicate over those ports. Can you open the controller GUI for that robot in IM? You'll find it eventually.