DX Infrastructure Manager

Expand all | Collapse all

"Plugin packages are not installed" error while configuring Isilon Monitoring via RESTMON Probe

  • 1.  "Plugin packages are not installed" error while configuring Isilon Monitoring via RESTMON Probe

    Posted 15 days ago
    Hi,

    We are trying to setup Isilon monitoring using the RESTMON Probe.
    When configuring the Isilon_schema with te correct details and credentials, the following error is shown: "Plugin packages are not installed"
    On the CentOS7 Hub the following probes have been deployed:
    * Robot_update 9.33
    * java_jre 2.05
    * restmon 1.41
    * isilon_monitoring 1.11.1 (created with the isilon_schema.json)

    Not sure what I'm missing here.

    Regards,

    Etienne

    ------------------------------
    Support Consultant
    Proact Netherlands BV
    ------------------------------


  • 2.  RE: "Plugin packages are not installed" error while configuring Isilon Monitoring via RESTMON Probe

    Broadcom Employee
    Posted 9 days ago
    stop the nimsoft robot watcher service
    rename the $\Nimsoft\plugins directory
    start the service
    redeploy robot_update

    ------------------------------
    Support Engineer
    Broadcom
    ------------------------------



  • 3.  RE: "Plugin packages are not installed" error while configuring Isilon Monitoring via RESTMON Probe

    Broadcom Employee
    Posted 7 days ago
    From the console delete restmon from the robot, then remove the restmon folder on disk at the robot.
    Verify $Nimsoft\plugins\plugin_metric was created.
    Remove the isilon profile from the device.
    Add the profile back again and try it out, letting mcs handle the deployment of restmon and the isilon probe.

    ------------------------------
    Support Engineer
    Broadcom
    ------------------------------



  • 4.  RE: "Plugin packages are not installed" error while configuring Isilon Monitoring via RESTMON Probe

    Posted 5 days ago
    Hi David,

    Thank you for the action plan.
    Unfortunately the problem still exists after following the provided steps:

    I can confirm that the restmon probe has been (re)deployed automatically.
    Might there be something else wrong?
    Thanks.

    Regards,

    Etienne

    ------------------------------
    Support Consultant
    Proact Netherlands BV
    ------------------------------



  • 5.  RE: "Plugin packages are not installed" error while configuring Isilon Monitoring via RESTMON Probe

    Broadcom Employee
    Posted 4 days ago
    Was going to provide some info to setup logging, however it came into my head, what if, this is compatibility.
    https://techdocs.broadcom.com/content/dam/broadcom/techdocs/us/en/dita/ca-enterprise-software/it-operations-management/unified-infrastructure-management/uim203-flattened/topics/Platform_Support_Availability_203.pdf
    It is showing restmon for RHEL 6 & SUSE 11, but nothing for CentOS. :(

    ------------------------------
    Support Engineer
    Broadcom
    ------------------------------



  • 6.  RE: "Plugin packages are not installed" error while configuring Isilon Monitoring via RESTMON Probe

    Posted 4 days ago
    Hi David,

    Didn't notice that.
    No problem, I'll try to deploy a Windows OS and give it another try.
    Thanks.

    Regards,

    Etienne.

    ------------------------------
    Support Consultant
    Proact Netherlands BV
    ------------------------------