DX Infrastructure Management

Expand all | Collapse all

upgrade to cabi 3.40 gives errors

  • 1.  upgrade to cabi 3.40 gives errors

    Posted 12-05-2019 06:08 AM
    Hello,

    After experiening this issue on one of my customer site, I've decided to build a server with UIM 9.0.2 and UMP 9.0.2 and cabi 3.32 and all work OK but after deploying cabi 3.40, the probe could not get started and throws these errors.

    By the way, I've NOT changed the default password in CABI.

    ...
    Dec 04 22:41:13:015 [main, cabi] request failed: (4) not found, Received status (4) on response (for sendRcv) for cmd = 'probe_config_get' name = 'wasp'Dec 04 22:41:13:015 [main, cabi] request failed: (4) not found, Received status (4) on response (for sendRcv) for cmd = 'probe_config_get' name = 'wasp'Dec 04 22:41:13:015 [main, cabi] (4) not found, Received status (4) on response (for sendRcv) for cmd = 'probe_config_get' name = 'wasp' at com.nimsoft.nimbus.NimSessionBase.sendRcv(NimSessionBase.java:622) at com.nimsoft.nimbus.NimSessionBase.sendRcv(NimSessionBase.java:573) at com.nimsoft.nimbus.NimClientSession.send(NimClientSession.java:173) at com.nimsoft.nimbus.NimRequest.sendImpersonate(NimRequest.java:264) at com.nimsoft.nimbus.NimRequest.sendImpersonate(NimRequest.java:237) at com.nimsoft.nimbus.NimRequest.send(NimRequest.java:208) at com.ca.cabi4uim.utilities.ProbeUtils.request1(ProbeUtils.java:383) at com.ca.cabi4uim.utilities.ProbeUtils.request(ProbeUtils.java:391) at com.ca.cabi4uim.utilities.ProbeUtils.waspConfigGet(ProbeUtils.java:234) at com.ca.cabi4uim.utilities.ProbeUtils.waspConfigGetAndHandleKeyNotFoundCondition(ProbeUtils.java:661) at com.ca.cabi4uim.utilities.ProbeUtils.isWaspSaaS(ProbeUtils.java:629) at com.ca.cabi4uim.Probe.setupcabi(Probe.java:368) at com.ca.cabi4uim.Probe.initOnTimer(Probe.java:698) at com.nimsoft.nimbus.NimProbe.doForever(NimProbe.java:418) at com.ca.cabi4uim.Probe.run(Probe.java:888) at com.ca.cabi4uim.Probe.main(Probe.java:120)
    Dec 04 22:41:14:671 [main, cabi] nimEx.getCode()=4, nimEx.getMsgForCode()=not found, nimEx.getMessage()=Received status (4) on response (for sendRcv) for cmd = 'probe_config_get' name = 'wasp'Dec 04 22:41:14:671 [main, cabi] ignoring the message as the key might not net set; logging it for tracking later Received status (4) on response (for sendRcv) for cmd = 'probe_config_get' name = 'wasp'Dec 04 22:41:14:674 [main, cabi] java.util.concurrent.TimeoutException: cabi webapp at 'http://10.5.0.4:80/cabijs' failed to start in 10 minutes at com.ca.cabi4uim.utilities.ProbeUtils.waitForWaspAndWebappToStartupCompletely(ProbeUtils.java:1713) at com.ca.cabi4uim.Probe.makeSureCabijsWebappIsUp(Probe.java:483) at com.ca.cabi4uim.Probe.createRestUser(Probe.java:620) at com.ca.cabi4uim.Probe.setupCabiInBundledMode(Probe.java:424) at com.ca.cabi4uim.Probe.setupcabi(Probe.java:351) at com.ca.cabi4uim.Probe.initOnTimer(Probe.java:698) at com.nimsoft.nimbus.NimProbe.doForever(NimProbe.java:418) at com.ca.cabi4uim.Probe.run(Probe.java:888) at com.ca.cabi4uim.Probe.main(Probe.java:120)
    Dec 04 22:41:14:674 [main, cabi] setting the lastInstallStatus=4Dec 04 22:41:14:674 [main, cabi] successfully set the lastInstallStatus=4Dec 04 22:41:14:675 [main, cabi] srcFilePath=C:\Program Files (x86)\Nimsoft\probes\service\cabi\cabi.log, srcFilePath.exists=true, tgtFilePath=C:\Program Files (x86)\Nimsoft\probes\service\cabi\cabi_install_archive.log, tgtFilePath.exists=trueDec  4 22:41:15:676 [4408] Controller: Probe 'cabi' (command = <startup java>) returns no-restart code (42)

    Anyone experiencing this issue ?

    Regards,
    Philong
     Original Message


  • 2.  RE: upgrade to cabi 3.40 gives errors

    Posted 12-05-2019 08:01 AM
    Hi Philong,

    We have seen a few cases like this. Please refer to:

    https://ca-broadcom.wolkenservicedesk.com/external/article?articleId=97227

    Steve

    ------------------------------
    Support Engineer
    Broadcom
    US
    ------------------------------



  • 3.  RE: upgrade to cabi 3.40 gives errors

    Posted 12-05-2019 08:59 AM
    Thanks Steve,

    I tried that already but the problem only arises after deployment of the probe cabi v3.40 !!

    Regards,
    PhN


  • 4.  RE: upgrade to cabi 3.40 gives errors

    Posted 12-05-2019 11:35 AM
    Hi PnH,
    Running cabi on 9.02 was a nightmare. I never got it to work but when I upgraded to 9.2.0 then deployed cabi v4.10 it worked. Can you upgrade to 9.20?


    ------------------------------
    Daniel Blanco
    Enterprise Tools Team Architect
    DBlanco@alphaserveit.com
    ------------------------------